Opened 14 years ago

Closed 14 years ago

Last modified 13 months ago

#2173 closed defect (fixed)

PSP: Save Game Issues

Reported by: SF/deepdene Owned by: joostp
Priority: normal Component: Port: PSP
Keywords: Cc:
Game:

Description

In two games now I have had problems saving the games.

Details are as follows:
PSP firmware 1.5
ScummVM Version: PSP Beta 4
Games:
Monkey Island 1 (CD Version)
Broken Sword 1 (2 CD Version) with mp3 compressed music
and speech

Description:
When saving games on the PSP for two games so far,
Broken Sword 1 and Monkey Island 1, at times depending
on the length of operation of the game.

This will often happen when the autosave happens on the
PSP in Monkey Island 1, and will often happen when
flying over to the Ireland level in Broken Sword 1.

Symptoms of the bug, will have a error message it
cannot save the state data in Monkey Island 1 when
trying to save the autosave file.

In both games, the listings of all the previously
listed files will disappear. So I tend to use a lot of
dot's getting the square button, and all these listings
will disappear.

So it seems that the ScummVM is unable to access the disk.

I will compile with the latest CVS version of the
ScummVM version, and update if this bug has been resolved.

Ticket imported from: #1276592. Ticket imported from: bugs/2173.

Change History (16)

comment:1 by joostp, 14 years ago

Interesting.
I personally haven't had any issues with the following SCUMM
games: MI2, DOTT, S&M, Full Throttle and COMI.
Several people have finished MI1 on PSP, which is a SCUMM
game as well, so it's interesting that this particular game
exhibits the behaviour for you.

There have been some other reports about BS1 not being able
to find its files and/or saving. I'll look into it.

comment:2 by joostp, 14 years ago

Owner: set to joostp

comment:3 by SF/deepdene, 14 years ago

Some further information based on the latest ELF I received.

It provides two extra error messages when trying to save out.

First "Unable to create file <filename details>" and "Unable
to create path <savegame path>"\

comment:4 by SF/deepdene, 14 years ago

This problem seems to extend to having no disk access
whatsoever, when i was trying to load another scene i hadn't
been in b4, it said "unable to load cluster paris4.clu". I
am assuming it is the same problem, since when i went back
into the game everything was fine with that particular
scene, however, i didn't go into the save screen before hand
so this may be a separate bug but it has the same symptons
of the save issue.

comment:5 by joostp, 14 years ago

So, to clarify; the problem with BS1 starts happening when
transitioning between the 1st and 2nd (Ireland) CD?

comment:6 by SF/deepdene, 14 years ago

I can't confirm it's the 1st and 2nd CD transitioning,

The bug does seem to happen on screen transitions however,
and most of the time (70%) if happens after playing the game
for at least 20 minutes.

comment:7 by SF/deepdene, 14 years ago

Attaching a file, after solving the puzzle with the chess
board, it'll take you back to paris. After leaving the
apartment you cannot save.

comment:8 by SF/deepdene, 14 years ago

For further information, I have been playing through Broken
Sword 2 with a recent CVS copy given to me by JoostP and
have had no problems with the saving of the game. So seems
isolated down to just Broken Sword 1 at this stage and maybe
Monkey Island 1.

comment:9 by SF/sfaok, 14 years ago

Upon starting a new game in MI1 CD version it refuses to
save after 15-20 minutes; a message appears indicating
that the auto-save has failed to save properly and any
subsequent saves are missing until scummvm is restarted.

Curiously, I couldn't reproduce this bug when using a
saved game before the bug occurred and it played without
the save glitch for the best part of 30 minutes or so.

comment:10 by SF/shaddowxxx, 14 years ago

Hi, i seem to be having the some of the same issues, mainly
the "cannot load cluster file xxxx.clu" and the cannont save
issues. You can sometimes work around it by removing either
the sound folder or the speech folder, although its hardly a
guarenteed way of it working.

As for the save issues, its usually quite random for me.
"Unable to create file <filename details>" pops up when
trying to save also

comment:11 by SF/themmaster, 14 years ago

I have done a little debugging together with joostp, and we
came to the conclusion that the most likely culprit is that
PSP doesn't seem to like to open more than 8 files at a
time, the 9th file will return a null pointer, and, the game
will thus be unable to continue.

for BS1, I have edited sword1/resman.h to scale the maximum
able open files down to 4 instead of 8, so far, I have not
had any problems.

I have attached a tar.bz2 that holds scummvm-0.8.0 for the
different firmware versions, please test, or, build for
yourself.

PLEASE NOTE THAT THIS DOES *NOT* SOLVE THE MI1 ISSUE!!!!
don't even try, it won't make ANY difference. We are still
investigating why mi1 has so many open files in the first place.

comment:12 by SF/themmaster, 14 years ago

OK... I can not, in fact, attach a file... get it here:

http://braam.sytes.net/~hp/scummvm/psp-bs1-hack.tar.bz2

sorry

comment:13 by joostp, 14 years ago

...and the problem with MI1 (and, AFAICT, all SCUMM games
that use CDDA tracks) is that it doesn't close the audio
files (mp3, in this case) after playing them.

This would also explain why this phenomenon only appears
after a while of playing (i.e after. 7 or 8 audio tracks
have played).

Shouldn't be too hard to fix this bug now.

comment:14 by joostp, 14 years ago

This should now be fixed in CVS - closing this report.

comment:15 by joostp, 14 years ago

Resolution: fixed
Status: newclosed

comment:16 by digitall, 13 months ago

Component: --Unset--Port: PSP
Note: See TracTickets for help on using tickets.