Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2163 closed defect (wontfix)

MM C64: Mouse Buttons not working

Reported by: SF/jonww Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

ScummVM version 0.8.0 CVS

Unknow MD5 (eea4d9ac2fb6f145945a308e8866915b)!
Please report the details (language, platform, etc.) of
this game to the ScummVM team
C64 V1 game detected

Language: English

Platform (Win32 & PSP)

Ticket imported from: #1265178. Ticket imported from: bugs/2163.

Change History (15)

comment:1 by fingolfin, 14 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by fingolfin, 14 years ago

Status: newpending

comment:3 by SF/jonww, 14 years ago

Status: pendingnew

comment:4 by SF/jonww, 14 years ago

* ScummVM version 0.8.0CVS/daily build Aug 20.
* Mouse buttons not funtioning. (In title screen)
* Language of game: English
* Version of game: Commodore 64
* Platform: Win32 & PSP
* N/A (happens at title screen)

comment:5 by SF/jonww, 14 years ago

Summary: Mouse Buttons not workingManiac64: Mouse Buttons not working

comment:6 by SF/jonww, 14 years ago

* ScummVM version 0.8.0CVS/daily build Aug 20.
* Mouse buttons not funtioning. (In title screen)
* Language of game: English
* Version of game: Commodore 64
* Platform: Win32 & PSP
* N/A (happens at title screen)

comment:7 by SF/jonww, 14 years ago

Status: newpending

comment:8 by fingolfin, 14 years ago

Owner: set to joostp
Status: pendingnew

comment:9 by joostp, 14 years ago

Uh, why is this assigned to me? It's not PSP specific, is it?

comment:10 by fingolfin, 14 years ago

Sorry, apparently I forgot to paste in the comment:

"I can't reproduce this problem on OSX, and MM64 so far
worked perfectly well everywhere. Only thing I can imagine
is that this is somehow a bug in the PSP port. Assigning to
joostp."

comment:11 by SF/jonww, 14 years ago

It doesn't work for me on Win32 ScummVM 0.8.0CVS
(Aug 20 2005 09:40:26) as well for me.

comment:12 by joostp, 14 years ago

I don't own the C64 version of Maniac Mansion so
unfortunately I can't test this.
FWIW, my MM V2 and the V1 one that's included with DOTT work
fine for me on PSP.

Are you sure none of the datafiles got damaged when copying
the files from your C64 media? As I see ScummVM also
reports an unknown MD5 for you.

comment:13 by fingolfin, 14 years ago

Status: newclosed

comment:14 by fingolfin, 14 years ago

Ah. Well, I just noticed that you say you have the C64 version of the
game... do you really mean the C64 version (taken from C64 media), or
do you mean the classic V1 PC version?
Considering your MD5 is unknown, I guess you may really have some
kind of C64 version... In that case you are out of luck, we do not yet
support that version of Maniac Mansion (see also our compatibility
chart)! There has been some work done on this, but it's not yet
complete.

Once we have officially announced that we support MM C64, and report
so on our web site, feel free to search for bugs in it.

comment:15 by fingolfin, 14 years ago

Owner: changed from joostp to fingolfin
Resolution: wontfix
Summary: Maniac64: Mouse Buttons not workingMM C64: Mouse Buttons not working
Note: See TracTickets for help on using tickets.