Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2130 closed defect (fixed)

ITE: Subtitles get striped

Reported by: sev- Owned by: sev-
Priority: high Component: Engine: SAGA
Keywords: Cc:
Game: Inherit the Earth

Description

Some subtitles get stripped. A good example of it is
armory at dog's castle. When you pass by guards one of
them says "Hey, I see a fox!" and another replies with
"Not that old trick (hic)...you're not peeking at my
cards.." but ScummVM shows just "Not that old".

Any platform, current CVS. Attached savegame which
works with every version of game.

To reproduce go right, skip dialog and go right again,
watch dogs talk.

Ticket imported from: #1257110. Ticket imported from: bugs/2130.

Attachments (1)

ite.s39 (5.4 KB ) - added by sev- 14 years ago.
Savegame near armory. Any ITE version

Download all attachments as: .zip

Change History (5)

by sev-, 14 years ago

Attachment: ite.s39 added

Savegame near armory. Any ITE version

comment:1 by eriktorbjorn, 14 years ago

I'm probably stating the obvious here, but the subtitles are
drawn by Font::textDrawRect(). In this case, it looks like
word "trick...(hic)...you're" is too long to fit on one
line, though another case where the subtitles would be
truncated is if the wrapped text gets too tall for the
rectangle.

comment:2 by sev-, 14 years ago

Status: newclosed

comment:3 by sev-, 14 years ago

Owner: set to sev-
Resolution: fixed

comment:4 by sev-, 14 years ago

Fixed in CVS

Note: See TracTickets for help on using tickets.