Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#2104 closed defect (wontfix)

MI2 (CD): crash when scrolling inventory (italian version)

Reported by: SF/lordlarry_it Owned by:
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

------------------ BUG ---------------------
ScummVM version: 0.7.0 & 0.7.1
Language of game: Italian (for sure)
Version of game: MI2 Italia, CD version (for sure)

When trying to scroll up inventory, game suddenly
crashes! To be noted that it's not at the begin or the end
of inventory, because there are other objects that
Guybrush have but can't be seen during scrolling cause
the crash!
I think that this may be a serious bug, because may
block to complete the adventure, and pheraps may
occur on other games, even if it hasn't been reported yet.
-------------------------------------------------
Really great work! Nice job, you're great!
Bye from Italy!

PS: I'll install a C++ compiler trying to find the bug. I
hope to help you, if I can ;)

Ticket imported from: #1248622. Ticket imported from: bugs/2104.

Attachments (1)

monkey2.s01 (15.5 KB) - added by SF/lordlarry_it 14 years ago.
savegame where bug can be tested

Download all attachments as: .zip

Change History (35)

Changed 14 years ago by SF/lordlarry_it

Attachment: monkey2.s01 added

savegame where bug can be tested

comment:1 Changed 14 years ago by SF/lordlarry_it

Priority: normalblocker

comment:2 Changed 14 years ago by fingolfin

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 Changed 14 years ago by fingolfin

Priority: blockernormal
Status: newpending

comment:4 Changed 14 years ago by SF/lordlarry_it

Status: pendingnew

comment:5 Changed 14 years ago by SF/lordlarry_it

Yes, sorry for incomplete infos:

* ScummVM version 0.7.1 (Mar 27 2005 10:51:21)
* details already reported before ^^^
* Language: Italian/DOS
* Version: CD (with code protection disabled)
* Platform compiler: Win32

I tested both latest version than 0.7.0

Thank you!

comment:6 Changed 14 years ago by sev-

As first item in tat list says, PLEASE test the latest
CVS/Daily build. You may find it on the bottom of our
downloads page. That is 0.8.0CVS.

comment:7 Changed 14 years ago by SF/lordlarry_it

Sorry...where may I found the CVS/Daily build?
"Build" stays for already compiled? Otherwise, what's your
favourite compiler?

Thank you!!!

comment:8 Changed 14 years ago by cyxx

As sev already mentionned, you can found the "win32 daily
snapshot" on the download page. Here's the direct link :
http://www.scummvm.org/downloads/scummvmwin32.exe

Also, if you see error messages when you experience the
crash, please, report them here.

comment:9 Changed 14 years ago by sev-

What is the status of this item?

comment:10 Changed 14 years ago by sev-

What is the status of this item?

comment:11 Changed 14 years ago by sev-

Priority: normalhigh

comment:12 Changed 14 years ago by sev-

This is a critical bug. Raising priority.

And what is the staus of this?

comment:13 Changed 14 years ago by sev-

Also please, run game with -d9 command line switch and
provide output it gives right before crash (30 lines will be
sufficient). And this should be tested with daily snapshot.

comment:14 Changed 14 years ago by fingolfin

Still awaiting response by the bug poster -- without feedback, we can't do
anything about this issue, I am afraid :-/

comment:15 Changed 14 years ago by SF/joachimeberhard

Dear ScummVM Team!

I have tried to reproduce this bug with exactly this italian CD
Version.

I wasn't able to reproduce this bug with CVS 10/16/2005.

I did'nt really play the game (I don't speak Italian, but the
word jokes I tell ya! ;-) ) but I did collect 4 rows of inventory
items, used them, stayed at last row when using an item, so
it would be empty afterwards, then scrolled up and tried
almost every thing regarding the inventory.

Everything worked as it should.

Inventory scrolling works perfectly for me.

But again: I didn't complete the game.

Best regards

Joachim Eberhard

comment:16 Changed 14 years ago by fingolfin

Hi Joachim,

thanks for that. Now, there is a savegame attached to this report (just
scroll to the bottomt of this page). Could you download this computer and
try to reproduce the problem with that savegame? That would be very
helpful!

comment:17 Changed 14 years ago by SF/joachimeberhard

Will try now.

Is the save for 080CVS?

I have already played Mi2 Italian CD to PartIII (LeChuck's
fortress).

I am currently stuck there because I don't know
head/feet/hip/arms in italian!

And believe me:
This was NOT FUN at all and spoiled the game for me.

I will try to complete it AND use this savegame.

Until then

Joachim

comment:18 Changed 14 years ago by SF/joachimeberhard

I can reproduce this bug with this savegame.
With what version of ScummVM has this savegame been
stored? Does this make any difference?

I cant scroll up above the library card, however, I can scroll
down to the bottom and scroll up to the library card again,
but no further.

I don't know yet what happens, if I try to finish the game
myself.

I will look up those italian words in a dictionary.

See ya

Joachim

comment:19 Changed 14 years ago by SF/joachimeberhard

I have successfully finished MI2 ITALIAN CD with CVS
10/16/2005.

I did not encounter ANY bugs except 2 line feeds even I
recognized as wrong.

Shall I file those 2 incidents I have found?

I DID NOT ENCOUNTER A INVENTORY BUG STARTING
THE GAME FROM SCRATCH.

But I have to say that SF Bugtrackers are HORRIBLE.

Every page takes AT LEAST 2 minutes to show and most
often, when I file a report, the "page cannot be found"
resulting in my report beeing gone. *Grunt*

Also, it almost takes 1day until I get emails from SF.

Best regards

Joachim Eberhard

comment:20 Changed 14 years ago by fingolfin

Your SF.net problems sound odd, maybe something is wrong with your
computer. While SF.net isn't the fastest site, over here loading a page
takes about 5 seconds. And I never ever see "Page not found
errors" (unless I manually enter URLs which I usually mistype, that is :-)...

Regarding the bug report: Maybe the savegame is corrupt, then... Hm

comment:21 Changed 14 years ago by SF/lordlarry_it

Sorry for delay, but I didn't hope you'd try the bug I had.

Here are some last lines of -d9 execution with rel. 0.7.1 (mar
27 2005):
---------------------
Script 9, offset 0xa1: [8B] o5_getVerbEntrypoint()
readvar(16386)
getResourceAddress(Inventory,10) == 014C8714
findResource(BREV, 14c8714)
Assertion failed: verbptr, file scumm/script.cpp, line 156
-------------------------------
Same error, but different line, with the latest build, rel.
0.8.0pre (Oct 21 2005)
-------------------------------
writeVar(136, 287)
Script 9, offset 0x9c: [A8] o5_notEqualZero()
readvar(16386)
Script 9, offset 0xa1: [8B] o5_getVerbEntrypoint()
readvar(16386)
getResourceAddress(Inventory,10) == 0951F364
findResource(BREV, 951f364)
Assertion failed: verbptr, file scumm/script.cpp, line 168
-------------------------------

I think this is a problem with a verb pointer of Italian version...

I hope it may help you. If you try the savegame, it's not
necessary to know Italian, because is enough to scroll up
inventory. Anyway:
head=testa/feet=piede/hip=anca/arms=braccia

Thank you and good luck!

comment:22 Changed 14 years ago by SF/lordlarry_it

What is the status of this item?

comment:23 Changed 14 years ago by SF/joachimeberhard

Dear Lord Larry (Never thought I'd ever say that ;-) )!

I have successfully finished MI2 Italian CD already with latest
0.8.0CVS.

I did not encounter this bug there.

I did try your savegame also, but it is a 0.7.0 Savegame.
And yes, the crash happens there WITH THIS **OLD**
SAVEGAME.

But if you try to complete the game USING 0.8.0 FROM
START!!!! this bug does not happen.

At least for me!

Please start MI2 Italian COMPLETELY from the beginning
with 0.8.0PRE to see if the bug is still there!

And: I am not in any way a member of the ScummVM team.
I am just someone who wants to help them.

Best regards

Joachim

comment:24 Changed 14 years ago by SF/lordlarry_it

What is the status of this item?

comment:25 Changed 14 years ago by SF/lordlarry_it

Dear Joachim,
thank you for your answer. I hope you didn't play whole Italian
version for me!!! I believe to you when you tell you complete
the game. But if I can't scroll up inventory, it's because
there's some bug to solve, evidently. I've tried the savegame
with latest version you mencioned (0.8.0pre) too, which one
is compatible.
Now, I prefer to let programmers to find this bug, then end the
game from the point I'm arrived, which is real near the end!
I repeat the debug lines for convenience:

Here are some last lines of -d9 execution with rel. 0.7.1 (mar
27 2005):
---------------------
Script 9, offset 0xa1: [8B] o5_getVerbEntrypoint()
readvar(16386)
getResourceAddress(Inventory,10) == 014C8714
findResource(BREV, 14c8714)
Assertion failed: verbptr, file scumm/script.cpp, line 156
-------------------------------
Same error, but different line, with the latest build, rel.
0.8.0pre (Oct 21 2005)
-------------------------------
writeVar(136, 287)
Script 9, offset 0x9c: [A8] o5_notEqualZero()
readvar(16386)
Script 9, offset 0xa1: [8B] o5_getVerbEntrypoint()
readvar(16386)
getResourceAddress(Inventory,10) == 0951F364
findResource(BREV, 951f364)
Assertion failed: verbptr, file scumm/script.cpp, line 168
-------------------------------
Thank you again!

comment:26 Changed 14 years ago by sev-

Joachim, though your help is really appreciated :) I wish
most users could be like you and help developers with
bugfixing. Thanks a lot.

comment:27 Changed 14 years ago by fingolfin

lordlarry_it, we, the programmers, can do little to nothing
about your problem. First off, we don't have the italian
version, so we can't try it ourselves. Secondly, even if we
had, this seems like a savegame corruption issue, and if
that's the case, we can't do anything at all, I am afraid...
:-/ I really have no idea what else could cause your problem.

comment:28 Changed 14 years ago by sev-

Priority: highlow

comment:29 Changed 14 years ago by sev-

Okay, lowering priority and move out of critical bugs list.

comment:30 Changed 14 years ago by SF/lordlarry_it

What is the status of this item?

comment:31 Changed 14 years ago by SF/lordlarry_it

Dear fingolfin,
first of all, thank you very much for the great work you've
done. This emulator is great!!!

The bug that I found seems to be not frequent, so I think at
this point you should close it. At this point I think it's
unuseful for you to bring ahead a bug you can't track.
Go on with this great work. You're great!

Cheers
Lorenzo from Italy

comment:32 Changed 13 years ago by fingolfin

Summary: MI2 (CD): game crashes when trying to scroll up inventoryMI2 (CD): crash when scrolling inventory (italian version)

comment:33 Changed 13 years ago by sev-

Closing as requested.

comment:34 Changed 13 years ago by sev-

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.