Opened 14 years ago

Closed 14 years ago

#2091 closed defect (invalid)

ALL: Mouse Cursor is leaving traces

Reported by: SF/poenn Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

When playing a game in fullscreen mode on Mac OS X 10.4.2 the
mouse cursor is leaving traces and after a while you barely can
see anything.
I attached a screenshot of Indy 3 256 DOS with this happening.

Ticket imported from: #1237449. Ticket imported from: bugs/2091.

Attachments (1)

Bild 2.png (63.7 KB ) - added by SF/poenn 14 years ago.
mouse cursor traces

Download all attachments as: .zip

Change History (12)

by SF/poenn, 14 years ago

Attachment: Bild 2.png added

mouse cursor traces

comment:1 by fingolfin, 14 years ago

Status: newpending
Summary: Fullscreen Mode in OS X: Mouse Cursor is leaving tracesALL: Mouse Cursor is leaving traces

comment:2 by fingolfin, 14 years ago

We need more information to say anything sensible about your report:
* Does this happens in-game or while the GUI is visible?
* Which version of ScummVM do you use?
* Which scaler do you use?
* What screen resolution?
* ...
This could be a duplicate of <https://sourceforge.net/tracker/index.php?
func=detail&aid=1185275&group_id=37116&atid=418820>

comment:3 by SF/poenn, 14 years ago

Hi, here's what I did use:

- scummvm 0.7.1.app
- happens in-game and in the initial gui where you can select options,
add games, etc.
- happens with all scalers as long as I use fulscreen, in windowed mode
all is fine.
- my display is set to 2560x1600, but I don't know if scummvm switches
to a lower resolution when starting, it does not seem like it does.

Let me know if I can help with additional infos!
Thanks
Bjrn

comment:4 by SF/poenn, 14 years ago

Status: pendingnew

comment:5 by sev-, 14 years ago

hmm. at 0.7.1 we didn't use independent cursor scalers. So I
wonder what could be the reason. Maybe broken SDL? Anyway
our GUI code is changed significantly in CVS version so IMHO
no reason to tackle old code.

comment:6 by sev-, 14 years ago

Status: newpending

comment:7 by sev-, 14 years ago

What is the status of this item?

comment:8 by SF/poenn, 14 years ago

Hi,

I've tested it again today. Though I still use the same OS and
ScummVM versions the traces seem to be gone. I did a few fullscreen
tests with indy3 and could not reproduce them. The only thing that got
updated in the meantime is QuickTime (7.0.3) but I suppose that
shouldn't have anything to do with it...

poenn

comment:9 by SF/poenn, 14 years ago

Status: pendingnew

comment:10 by sev-, 14 years ago

Resolution: invalid
Status: newclosed

comment:11 by sev-, 14 years ago

So definitely it is not our bug. Closing.

Note: See TracTickets for help on using tickets.