Opened 17 years ago

Closed 17 years ago

Last modified 6 years ago

#209 closed defect (invalid)

Recent CVS builds crash on load game

Reported by: SF/beefheart Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

I've experienced this with both Indy and DOTT. When I
try to load a savegame with recent cvs builds, scummvm
crashes with the message:

Error: Out of memory while allocating 1085558796!

which looks very much like the good ole' unitialized
variable :) Savegame included. (this is on linux btw,
last tried with the 20020502 build). It works with the
0419 build.

Ticket imported from: #551365. Ticket imported from: bugs/209.

Attachments (1)

tentacle.s07 (51.6 KB ) - added by SF/beefheart 17 years ago.
Example savegame that crashes

Download all attachments as: .zip

Change History (6)

by SF/beefheart, 17 years ago

Attachment: tentacle.s07 added

Example savegame that crashes

comment:1 by SF/inguin, 17 years ago

Guess they changed the file format. They do that from time to time, just to make sure you have to play through your games over and over again and report any new bugs. ;-)
Just kidding, but it's possible that savegames of different versions of ScummVM aren't compatible. I noticed that a few times before.

comment:2 by SF/logicdeluxe, 17 years ago

I noticed it on Windows, too. But this happens only to older
savegames to me. However, I didn't experience it with
savegames made with the same build of Scummvm.

I don't think it is a bug since readme.txt states:
'Also note that saved games can, and probably will, be
incompatible between releases.'

comment:3 by SF/ender, 17 years ago

Owner: set to SF/ender
Resolution: invalid
Status: newclosed

comment:4 by SF/ender, 17 years ago

This is not a bug, the save game format meerly changed
between those builds. This happens with the CVS, and is
mentioned in the readme as logicdeluxe pointed out.

Then again inguin has a good point to - no comment on that
one :)

comment:5 by Strangerke, 6 years ago

Component: --Unset--Engine: SCUMM
Owner: SF/ender removed
Note: See TracTickets for help on using tickets.