Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#2089 closed defect (fixed)

FOA: Look at Arnold (Fists Path)

Reported by: SF/paul66 Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

ScummVM 0.8.0CVS (Jul 6 2005 09:32:22)

Fists Path Indy can't look at Arnold, after he is crushed by the boulder. room 170 actor 12 (Boulder) is over actor 11 (Arnold) after actor 12 has an other costume (actor 12 custome 0 ) Indy can look at Arnold. it is a transparent problem at the boulder.

this bug are in FM-Towns and DOS (CD and Floppy) Platform: Win32

Ticket imported from: #1235863. Ticket imported from: bugs/2089.

Attachments (1)

atlantis.s22 (27.0 KB ) - added by eriktorbjorn 15 years ago.
Savegame before meeting Arnold

Download all attachments as: .zip

Change History (12)

comment:1 by fingolfin, 15 years ago

Summary: Indy4: Look at Arnold (Fists Path)FOA: Look at Arnold (Fists Path)

comment:2 by SF/daniel_oberg, 15 years ago

Same problem with platform OpenBSD 3.7.

ScummVM 0.8.0CVS (Jul 19 2005 00:58:14) Features compiled in: zLib

comment:3 by eriktorbjorn, 15 years ago

Has anyone checked whether or not the original interpreter behaved any different in this case?

comment:4 by SF/frank_m24, 15 years ago

I can confirm this problem with self compiled CVS from 2005- 07-29, mingw32 build. You have to look at Arnold in order to get the orichalcum detector. It is not possible to continue with the game without this detector (unable to find Sophia).

by eriktorbjorn, 15 years ago

Attachment: atlantis.s22 added

Savegame before meeting Arnold

comment:5 by eriktorbjorn, 15 years ago

Looks like you're right. I'm attaching a fresh savegame for the English talkie version which may be of help when investigating.

comment:6 by eriktorbjorn, 15 years ago

Hmm... Arnold appears to be actor 11 and the boulder is actor 12. If I hack the source code to prevent actor 12 from being drawn, I can interact with actor 11 again. Something with the graphics "usage bits", perhaps...?

comment:7 by eriktorbjorn, 15 years ago

Owner: set to Kirben

comment:8 by eriktorbjorn, 15 years ago

Ah, I see the problem: Our getActorFromPos() function used to return the first actor it found on the requested position, which would be Arnold since he has the lower actor number. On April 1 that was changed:

https://sourceforge.net/mailarchive/forum.php?thread_id=6950741&forum_id=33067

So now it will find the boulder instead, though for some reason it doesn't print any object name for it. Perhaps it doesn't have any. Once Arnold is dead, the boulder is basically irrelevant, after all.

Assigning to kirben, since he made the change.

comment:9 by Kirben, 15 years ago

Status: newclosed

comment:10 by Kirben, 15 years ago

Fixed in ScummVM cvs, the changes I made should have been HE70+ specific.

comment:11 by Kirben, 15 years ago

Resolution: fixed
Note: See TracTickets for help on using tickets.