Opened 14 years ago

Last modified 13 months ago

#2062 new defect

SAM: Crash entering Frog Rock first time (Spanish version)

Reported by: SF/loom2d Owned by:
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

-ScummVm Version 0.71

-When I hit the Frog Rock icon in the map ready to
enter for the fist time in this area,just after searching it
with the binoculars,the program exits and enters in
debugger mode:This is the error: "room 41 not in room
41 at 7393531 +0 in the file samnmax.001"

-Language:Spanish

-Version of the game:Cd-Rom

Platform:Win32

Tried with latest scummvm dialy Built and nothing .
I'm using Windows XP SP1

Ticket imported from: #1217608. Ticket imported from: bugs/2062.

Attachments (1)

samnmax.s07 (10.5 KB) - added by SF/loom2d 14 years ago.
Just enter Frog Rock icon

Download all attachments as: .zip

Change History (33)

Changed 14 years ago by SF/loom2d

Attachment: samnmax.s07 added

Just enter Frog Rock icon

comment:1 Changed 14 years ago by fingolfin

Are you playing straight from CD? This is not a good idea on Windows, as
explained in section 3.6 of the README.

comment:2 Changed 14 years ago by fingolfin

Summary: SamnMax:Crash when entering Frog Rock for the first timeSAM: Crash when entering Frog Rock for the first time

comment:3 Changed 14 years ago by eriktorbjorn

But that only applies to games that play CD audio tracks
from the CD, doesn't it? Sam & Max doesn't.

It may still be a good idea trying to copy the data files to
hard disk, of course, since that should make it more obvious
if the CD has somehow been damaged. It'd be useful if
someone who has the Spanish version could compare MD5 sums...

comment:4 Changed 14 years ago by SF/loom2d

I am playing it from hard disk.I copied all the data to my hd
and playing from there.If anyone with spanish version of Sam
& Max could confirm this problem it would help.This bug
makes Sam & Max Spanish Cd-Rom version unplayable till
the end.

Thanks for your time.Don't leave this bug unfixed please.

comment:5 Changed 14 years ago by SF/loom2d

What is the status of this item?

comment:6 Changed 14 years ago by SF/trinity78

In general I would say your data files are corrupt as the
problem is not reproducible (with my own savegames - german
version).
Error message (room x at xxxxxxxxx) like yours are usually
pointing to corrupt files.

Maybe someone who also has the spanish version, could
compare md5 checksums with you.

comment:7 Changed 14 years ago by SF/loom2d

Its impossible my files are corrupt cos i played this game
long time ago and could finish it.Even I recopied the game to
my hard disk and I had still the same problem entering Frog
Rock.
Recently someone give me an english version of Sam & Max
Cd-rom but I am lazy to play again;the spanish savegames
seems not to work with english version so if anyone could
send me an english savegame just when Sam and max are
entering Frog Rock...

comment:8 Changed 14 years ago by fingolfin

Uh, you played it a "long time ago", and that means it is impossible
that the files are corrupt ? CDs tend to get damaged over time,
and loosing data from old CDs (sadly) is a quite frequent thing.

Mind you, I don't say that a damaged data file must be the cause,
but nothing of what you say makes it less likely in my eyes...

comment:9 Changed 14 years ago by fingolfin

Priority: normalhigh

comment:10 Changed 14 years ago by SF/loom2d

Its true that old cds are loosing data over time, but mine
seems to be ok cos i have been able to copy all the data in
cd to my hard disk without any transfer error.

comment:11 Changed 14 years ago by SF/loom2d

What is the status of this item?

comment:12 Changed 14 years ago by fingolfin

Priority: highlow
Resolution: worksforme

comment:13 Changed 14 years ago by fingolfin

Please tell us the MD5 of your data files.

Other than that, I can only say that we can't reproduce your error.

comment:14 Changed 14 years ago by SF/loom2d

Here is the md5 i have obtained from file SAMNMAX.000
using the program WinMd5Sum:

4ba7fb331296c283e73d8f5b2096e551

I have included the file SAMNMAX.000 for your interest.

comment:15 Changed 13 years ago by fingolfin

Summary: SAM: Crash when entering Frog Rock for the first timeSAM: Crash entering Frog Rock first time (Spanish version)

comment:16 Changed 13 years ago by fingolfin

We need the MD5 checksum of *all* your data files to
find out whether they are damaged or not.

comment:17 Changed 13 years ago by SF/loom2d

Glad to see u want to fix this problem.For ur interest
recently I see in spanish forums some people having this
problem too.
Well here are the MD5 u requested:

BOOTMKR.EXE - 7da3bd1d43dde9cc4d6b9a857900964f
CDPLAY.EXE - a47f8fe2e39ddb3db6fabb1b4f22e1e8
DOS4GW.EXE - 15ff24d641ba6ad318362935147bc2fb
FM2.MSD - 7ff6726cfbf43ef9af290b47f8cc0155
FM4.MSD - 33ddf44b3571fd80577d39c8b65e6cc3
GMIDI.MSD - 88bb788bc59ab379499a9299b9631373
MONSTER.SOU - cdc4798d7b4005f069b5e69eefd81a4d
PAS.WSD - f175838f77821fae3e4dfc31b6b662f5
ROLAND.MSD - 50eec7d8ddfb3945cc42a4838bcce5ec
SAMNMAX.EXE - a3727ad12c3cb98cde6f682dd7cccebc
SAMNMAX.000 - 4ba7fb331296c283e73d8f5b2096e551
SAMNMAX.001 - 6644ac9d0a233dc608b4684f35a1c69e
SAMNMAX.RSC - a7eadf376685cf612de2f4d194c145dc
SB16.WSD - 7380c9f7c79380905db71f3dd8616373
SBCLONE.WSD - 2e583ac426a56af53fd3df3df9a5fd33
SBPRO.WSD - c11b836a8987c4cc355972d72aa3f986
SETMUSE.EXE - aefc7a68df5cea5cca42e09db10c9208
TESTMIDI - bf23ab9e4fe0069e484fc4aa55a77889
TESTWAVE - 81fa540e1b7564493e0a55c9216721ba

comment:18 Changed 13 years ago by sev-

What is the status of this item?

comment:19 Changed 13 years ago by sev-

Resolution: worksforme

comment:20 Changed 13 years ago by fingolfin

I actually emailed Andrea Petrucci today (who also owns the spanish version of
SAM), asking for a review of this item.

comment:21 Changed 13 years ago by SF/loom2d

What is the status of this item?

comment:22 Changed 13 years ago by SF/formulita

I had the same problem with the Spanish CD version of Sam &
Max, got a new SAMNMAX.001 file from a friend and overwrite
the one i have and the problem is gone. I you still got the
problem and need the file, let me known and i will send you
the new SAMNMAX.001 file by mail. cheers.

comment:23 Changed 13 years ago by SF/kaod_

Spanish CD-Rom Version here:

d337d7d9be77e5922b9a6e732f19d1e4 ./SAMNMAX.001

So, maybe he had corrupt data ?

Anyways, formulita had the same problem. Maybe theirs was a
different version than mine, valid too, but ScummVM has some
trouble hadling that version ?

comment:24 Changed 13 years ago by SF/loom2d

Thanks for your offer formulita,i have sent you a message
requesting u the file.

Maybe the file SAMNMAX.001 that is giving the error is
from an older version that formulita and i have both,the
one that came out in 90's.Now here in Spain this game has
been reedited and maybe the files has changed.So in that
case scummvm has problems handling with the older version
but not with the newer one.

comment:25 Changed 12 years ago by SF/chanchunflein

i had this problem too, i use the spanish cd version of sam
n max.

comment:26 Changed 12 years ago by SF/sirocs

¿Has this been solved? I'm using ScummVM 0.9.0 and the
spanish CD-ROM version of Sam and Max and I have the same
problem that describes this bug.

comment:27 Changed 12 years ago by eriktorbjorn

I don't think anyone has done anything about it
deliberately, at least. It's hard to debug a problem, when
you don't have that particular version of a game...

comment:28 Changed 12 years ago by SF/danielk_dk

I have the same ERROR. PLEASE HELP! I can't finish this fantastic adventure.

-I can send you an e-mail with the link of this CD VERSION(SPANISH) -Only to solve this BUG.

Please, if you want to have this version and solve the BUG, only send me your mail to:
danielk_dk@yahoo.es

comment:29 Changed 12 years ago by fingolfin

We can *not* accept offers to send us copies of games in order to debug them, for legal reasons. You certainly have the best intentions, but your offer is illegal in many states, states where developers of this project reside.

If you really want to help, you should donate a proper, legal "copy" of the game -- go and buy another spanish SAM (maybe it's still sold over there, or maybe you can find one on ebay or so), and donate it to one of the devs. For example, if somebody sent me a spanish SAM CD, I'd be happy to look into the issue myself.

comment:30 Changed 8 years ago by SF/abevi

Just tested this and the problem persists (1.4.0git535)

with resource debugging on, this is the trace leading up to the error

ensureResourceLoaded(Room,93)
loadResource(Room,93)
_res->createResource(Room,93,9880)
getResourceAddress(Room,93) == 0x903c6b0
findResource(RMHD, 0x903c6b0)
findResource(CDHD, 0x903e854)
findResource(CDHD, 0x903e88a)
findResource(CDHD, 0x903e8c0)
findResource(CDHD, 0x903e8f6)
findResource(CDHD, 0x903e92c)
findResource(CDHD, 0x903e962)
findResource(CDHD, 0x903e998)
findResource(CDHD, 0x903e9ce)
findResource(CDHD, 0x903ea04)
findResource(CDHD, 0x903ea3a)
findResource(CDHD, 0x903ea70)
findResource(CDHD, 0x903eaa6)
findResource(CDHD, 0x903eadc)
findResource(CDHD, 0x903eb12)
findResource(CDHD, 0x903eb48)
findResource(CDHD, 0x903eb7e)
findResource(IMHD, 0x903ca4c)
findResource(IMHD, 0x903cb3c)
findResource(IMHD, 0x903ccdc)
findResource(IMHD, 0x903ce6e)
findResource(IMHD, 0x903d010)
findResource(IMHD, 0x903d1b2)
findResource(IMHD, 0x903d330)
findResource(IMHD, 0x903d4ae)
findResource(IMHD, 0x903d64e)
findResource(IMHD, 0x903d80a)
findResource(IMHD, 0x903d936)
findResource(IMHD, 0x903dad4)
findResource(IMHD, 0x903dc1a)
findResource(IMHD, 0x903de0a)
findResource(IMHD, 0x903dea2)
findResource(IMHD, 0x903e022)
findResource(IMHD, 0x903e022)
findResource(IM01, 0x903e022)
findResource(BOMP, 0x903e048)
ensureResourceLoaded(Room,41)
loadResource(Room,41)
Unknown res tag '..5.' encountered (expected 'ROOM') while trying to load res (Room,41) in room 41 at 7393531+0 in file samnmax.001!

I don't really know enough about the scumm engine to go any further, but since this is a really old defect, thought I'd try to help get it resolved ;)

comment:31 Changed 16 months ago by dafioram

I was able to complete this game very recently on the english/GOG version and I did not experience any issues so it is either specific to the spanish version, it is no longer present, or it is specific to the op's setup.

I think the next step is for someone with the spanish version to load the saved game and see if the bug is still present in the current scummvm.

comment:32 Changed 13 months ago by bonki

Confirmed working with the current Spanish GOG version which ships with the following files:

$ md5sum.exe SAM* MONSTER*
4ba7fb331296c283e73d8f5b2096e551 *SAMNMAX.000
d337d7d9be77e5922b9a6e732f19d1e4 *SAMNMAX.001
995205d23d65417890677e8043b4622b *MONSTER.SOU

$ stat SAM* MONSTER* | egrep "File|Size|Modify"
File: SAMNMAX.000
Size: 9080 Blocks: 12 IO Block: 65536 regular file
Modify: 1994-06-02 03:05:38.000000000 +0200

File: SAMNMAX.001
Size: 13794320 Blocks: 13472 IO Block: 65536 regular file
Modify: 1994-06-02 03:05:38.000000000 +0200

File: MONSTER.SOU
Size: 183195967 Blocks: 178904 IO Block: 65536 regular file
Modify: 1994-01-31 12:22:14.000000000 +0100

So either there is a buggy/non-supported alternative version out there or OP had corrupted files.

Last edited 13 months ago by bonki (previous) (diff)
Note: See TracTickets for help on using tickets.