Opened 14 years ago

Closed 12 years ago

Last modified 12 years ago

#2041 closed defect (fixed)

FOA AMIGA: Black cursor and text in Dig Site

Reported by: SF/grizzlybaer Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

• Version: ScummVM 0.8.0CVS (May 22 2005 20:47:23)
• Bug details:

Hi,
In the Amiga floppy disk version of Indiana Jones And
The Fate Of Atlantis, I encountered a problem that
hinders me from finishing the game. There is a scene in
the game (the dig site in the Algerian desert), where
the screen has to be totally black because it shall
resemble no light. But the problem in the Amiga version
is, when played with ScummVM, that not only the action
screen (the one above the inventory/verbs) is black,
but also the Cursor and the text line where items on
the screen and verb connections (Read Sign, Use Object
With Object) are black.
And therefore it is not possible to finish that game
scene because you cannot see which items are on screen
by positioning the mouse cursor above them as the text
and underground are both black (and the cursor, too).

I uploaded save states for the German and English
version of the game, created with the ScummVM version
of May 22nd '05. If you load them, Indy only has to
walk down the ladder in from of him to get to the
described area.

• Version and Language: Commodore Amiga, floppy disk
version, tested German and English.
• Used Platform: Win32
• Savegame 1: German Version
Savegame 2: English Version
• sorry, I do not know since when the bug is in ScummVM.

Ticket imported from: #1206994. Ticket imported from: bugs/2041.

Attachments (1)

IndJones4_digsitesaves-WIPmay22.rar (48.2 KB ) - added by SF/grizzlybaer 14 years ago.
Savestates from before the described area (01.German, 02.English)

Download all attachments as: .zip

Change History (16)

by SF/grizzlybaer, 14 years ago

Savestates from before the described area (01.German, 02.English)

comment:1 by fingolfin, 14 years ago

Summary: Indiana Jones 4 (Amiga v.),Black cursor and text in Dig SiteFOA: Black cursor and text in Dig Site (Amiga version)

comment:2 by fingolfin, 14 years ago

I haven't tested with current CVS, but the problem doesn't occur in the PC
version (though it won't hurt if somebody retests that). If this turn out to be
specific to the Amiga version, I am afraid there is little we can do to fix it,
since (AFAIK) nobody on the team has the Amiga version of FOA...

P.S.: Thanks for reading the bug submission text and filling in all the
useful info, I wish all users would do that. Very clear bug report., thanks

comment:3 by Kirben, 14 years ago

I noticed the color of subtitles and the sentance line are
different in ScummVM, when compared to the original game
in WinUAE.
So there is a palette difference in code or scripts, that we are
still missing somewhere, which I expect is the cause of this
bug.

comment:4 by fingolfin, 14 years ago

Summary: FOA: Black cursor and text in Dig Site (Amiga version)FOA AMIGA: Black cursor and text in Dig Site

comment:5 by fingolfin, 14 years ago

I assume this issue is still present... it's a bit hard to do anything about this w/o
having the Amiga version of FOA, sorry :-/

comment:6 by sev-, 13 years ago

Please test whether you can reproduce this bug
with the latest daily SVN build which you can find
at the bottom of our downloads page:
<http://www.scummvm.org/downloads.php>.

comment:7 by Kirben, 13 years ago

The problem still occurs, there have not been any changes
that would help this situation in ScummVM.

comment:8 by (none), 13 years ago

ScummVM 0.10.0svn (Jul 1 2006 23:52:39)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

The color of the objects and verbs are still much too dark
to read

comment:9 by (none), 13 years ago

Hmm, i'd add a screenshot, but i can't somehow ???

Anyway, fingolfin, if you need the Amiga version i'd gladly
donate my full packaged, fully working 11-disk Amiga
version, just let me know where to send it :-)

comment:10 by (none), 13 years ago

Here's an imageshack upload, dunno how long it will
be there, but anyway, just to give you an idea how
the bug looks alike:

The verbs section is fine, no problems, but the
game screen itself together with the cursor and
the command line is much too dark to do anything
feasable
http://img223.imageshack.us/my.php?image=grabfl4.jpg

comment:11 by sev-, 12 years ago

Owner: set to sev-

comment:12 by sev-, 12 years ago

Resolution: fixed
Status: newclosed

comment:13 by sev-, 12 years ago

Fixed in SVN.

comment:14 by sev-, 12 years ago

And backported to 0.11.0 branch too.

comment:15 by sev-, 12 years ago

If you, guys, could test this game a bit more, that would be good.

Potentially there are more palette-related bugs, as original code left actors colors unchanged when some particular amiga-specific flag is set. I have no idea where it is used, so I did not add that code.

Note: See TracTickets for help on using tickets.