Opened 17 years ago

Closed 17 years ago

Last modified 8 months ago

#204 closed defect (worksforme)

Linux midi

Reported by: SF/inguin Owned by: SF/ender
Priority: low Component: Port: Linux
Keywords: Cc:
Game:

Description

I'm sort of reopening bug report #546446 from a few weeks ago: Since the midi driver can be chosen at run time, Linux sequencer or Timidity output doesn't work any longer: If I run with -etimidity scummvm doesn't even start, telling me about "Invalid midi driver selected!". And if I use -eseq scummvm works fine, but there is no music at all.
Both modes used to work back when the midi driver was chosen at compile time. Adlib music works fine. Oh, and of course my SCUMMVM_MIDI environment variable points to /dev/sequencer.

Ticket imported from: #550350. Ticket imported from: bugs/204.

Change History (7)

comment:1 Changed 17 years ago by SF/inguin

Priority: normallow

comment:2 Changed 17 years ago by SF/ender

Owner: set to SF/ender

comment:3 Changed 17 years ago by SF/ender

Sequencer support works fine. Possibly something has
changed in your setup since then?

Timidity support has been removed for the moment, as we are
debating whether it is worth including in 0.2.0. As
timidity is... frankly, it's crap, for iMUSE games, we
probably won't include it again.

If you DO want it, there is a patch in the Patch Tracker to
reenable it.

comment:4 Changed 17 years ago by SF/inguin

I'm quite sure it's not my setup, because I still have an older version of ScummVM I built on April 11th using the D_MIDI define. And sequencer support works great with that one. I also made sure it's not just some mixer channel.
I don't really care about Timidity, since I couldn't get it working correctly on my system: If I run it normally it complains about not being able to write to /dev/dsp and quits instantly. I just gave it a try using the disk writer output. ;-)

comment:5 Changed 17 years ago by SF/ender

Resolution: worksforme
Status: newclosed

comment:6 Changed 17 years ago by SF/ender

-eseq works for other people, and I can't find anyone who
can replicate, so closing.

Use -emidiemu or -eadlib instead.

comment:7 Changed 8 months ago by digitall

Component: --Unset--Port: Linux
Note: See TracTickets for help on using tickets.