Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#203 closed defect (worksforme)

Crash in Loom

Reported by: (none) Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

I scare the shepherds in the woods in Loom. After
that, whenever I try to walk past the spot where
they're supposed to come out, ScummVM crashes. The
only thing it says is "fatal segmentation fault". I
can't go any further than this. I'm using the CVS
from April 28, 2002. I'm not sure if this only
happens on my computer, or not.

Ticket imported from: #550031. Ticket imported from: bugs/203.

Attachments (1)

VALGRIND_LOOM (14.5 KB) - added by SF/bbrox 17 years ago.
Valgrind trace of LoomCD

Download all attachments as: .zip

Change History (19)

comment:1 Changed 17 years ago by SF/ender

Please attach a saved game just before you do this.

comment:2 Changed 17 years ago by SF/ender

Owner: set to SF/ender

comment:3 Changed 17 years ago by (none)

Logged In: NO

I'm kind of stupid. How do I attach a file??

comment:4 Changed 17 years ago by SF/khalek_

I don't get this with latest cvs

comment:5 Changed 17 years ago by SF/khalek_

you have to login before you can attach files...

comment:6 Changed 17 years ago by SF/khalek_

bbrox: the save can be found
http://khalek.tolmie.net/loomcd.s02 use dffd to scare the
shepherds

comment:7 Changed 17 years ago by SF/ender

Resolution: worksforme
Status: newclosed

comment:8 Changed 17 years ago by SF/ender

Closing as actual crash is unreproducable. Apparantly mask
bugs still exist, or at least the shepards head won't draw.

khalek, your weave doesn't work :P

comment:9 Changed 17 years ago by SF/bbrox

Status: closednew

comment:10 Changed 17 years ago by SF/bbrox

Well, 'dffd' certainly does not work here... I tried 'cgcg'
which has some effects and 'gcgc' but it did not help either.

But well, are you sure you have saved at the right place ? I
think that you need first to learn the 'dffd' spell before
being able to cast it => if you saved too early, it won't work.

So I cannot reproduce the crash.

Changed 17 years ago by SF/bbrox

Attachment: VALGRIND_LOOM added

Valgrind trace of LoomCD

comment:11 Changed 17 years ago by SF/bbrox

Well, managed to get A LOT of warnings in Valgrind just by
walking from the forest to the Crystal City (without even
speaking to the shepherds).

But well, I am not competent enough in ScummVM internals to
debug this, so the trace is attached here :-)

comment:12 Changed 17 years ago by (none)

Logged In: NO

You couldn't do this crash on your computer? I'm using the
latest CVS right now as of 4/30/01, and it still happens.
I run ScummVM on Windows XP in full-screen, using the
AdvMame2x filter. I play Loom in PRACTICE mode.

comment:13 Changed 17 years ago by SF/ender

We have made one small fix already which may help a little -
although there is another obvious problem still remaining.
Give the latest CVS a try and see if it helps.

comment:14 Changed 17 years ago by SF/bbrox

Some follow ups : some warnings were fixed in the current
CVS, so people with crashes could retry (no promises though).

When walking from the save game to the Crystal City, a lot
of warnings occurs. According to Valgrind, if comes from the
fact that '_scaleIndexY' is not initialized properly in the
CostumeRenderer::proc1 function.

Will try to investigate further.

comment:15 Changed 17 years ago by SF/bbrox

After yet another commits, warnings disappeard from the
Valgrind trace. Could people having the crashes retry with
my latest commits ?

Thanks.

comment:16 Changed 17 years ago by SF/ender

Status: newclosed

comment:17 Changed 17 years ago by SF/ender

Closing again as this is definatly fixed now :)

comment:18 Changed 17 years ago by SF/ender

Closing again as this is definatly fixed now :)

Note: See TracTickets for help on using tickets.