Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#2012 closed defect (duplicate)

BASS: "Invalid Mode(16)" crash/exit

Reported by: SF/devon_miller Owned by: lavosspawn
Priority: low Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

When I attempt to interact with the travel agent after
obtaining the motorcycle magazine, the game immediately
closes and prints the error message: "Invalid Mode (16)!"

I am attaching a tarfile containing my .scummvmrc file
and .scummvm directory, and the stdout/stderr of this
command:
scummvm -d 6 -p /usr/share/games/bass sky

I renamed ".scummvmrc" to "dot.scummvmrc" and
".scummvm" to "dot.scummvm" to make sure there's no way
of accidentally overwriting someone elses saved games.

Ticket imported from: #1192991. Ticket imported from: bugs/2012.

Attachments (1)

bass-close.tar.bz2 (31.3 KB) - added by SF/devon_miller 14 years ago.
Saved game and output from scummvm -d6

Download all attachments as: .zip

Change History (15)

Changed 14 years ago by SF/devon_miller

Attachment: bass-close.tar.bz2 added

Saved game and output from scummvm -d6

comment:1 Changed 14 years ago by fingolfin

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 Changed 14 years ago by fingolfin

Component: Engine: Sky
Game: Beneath a Steel Sky
Status: newpending

comment:3 Changed 14 years ago by SF/devon_miller

Status: pendingnew

comment:4 Changed 14 years ago by SF/devon_miller

Scummvm: 0.7.1
BASS: English, freeware, CD dl'd from scummvm.org
Scummvm engine compiled on Gentoo Linux with gcc-3.3.5

comment:5 Changed 14 years ago by eriktorbjorn

I can reproduce it, but I have no idea what causes it.
(Probably because I'm not really involved with the BASS
engine. :-)

comment:6 Changed 14 years ago by fingolfin

Summary: "Invalid Mode(16)" crash/exitBASS: "Invalid Mode(16)" crash/exit

comment:7 Changed 14 years ago by fingolfin

Component: Engine: Sky
Game: Beneath a Steel Sky

comment:8 Changed 14 years ago by sev-

Priority: normalhigh

comment:9 Changed 14 years ago by sev-

This seems to be a release critical bug. Raising priority.

comment:10 Changed 14 years ago by lavosspawn

The cause is exactly the same as for the other reports in the
tracker.
A compact (in this case trevor, the travel agent) is waiting for
a sync signal that apparently got lost on the way.

The corresponding interpreter sourcecode is like 2 lines
long... so I still think it's a script bug, but the surprising
number of different occurences makes it a little hard to
believe.

comment:11 Changed 14 years ago by sev-

Owner: set to lavosspawn
Priority: highlow

comment:12 Changed 14 years ago by sev-

Same thing. Lowering priority but feel free to close it and
create Wiki page with add link to it on our FAQ.

comment:13 Changed 13 years ago by fingolfin

Closing this as a duplicate of bug report #1314495, where the issue in
described with some detail.

comment:14 Changed 13 years ago by fingolfin

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.