Opened 18 years ago

Closed 17 years ago

Last modified 17 years ago

#200 closed defect (fixed)

MI2: Verbs shadows missing

Reported by: SF/logicdeluxe Owned by: SF/ender
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

Built on Apr 27 2002 17:44:51
In Monkey1 and Monkey2 the verbs in the interface
should have a dark violet shadow, which is not there.

Ticket imported from: #549547. Ticket imported from: bugs/200.

Attachments (1)

monkey.s02 (34.8 KB ) - added by SF/logicdeluxe 17 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 by SF/ender, 18 years ago

This doesn't sound like something that could really affect
gameplay, so lowering priority to trivial.

comment:2 by SF/ender, 18 years ago

Priority: normallow

comment:3 by SF/logicdeluxe, 18 years ago

Built on Apr 28 2002 19:20:18
With Monkey1 it works now. However, if I load a savegame
which had not these shadows it remains without them. In
Monkey2 it is still missing at all.

comment:4 by SF/logicdeluxe, 18 years ago

Built on Apr 28 2002 19:20:18
It's hard to see, but actually there is a shadow. But it is
black instead of dark violet. And in Monkey1 I noticed now,
that it also becomes black again as soon as you got the
money from the circus.

comment:5 by fingolfin, 17 years ago

In current CVS, the MI1 verb shadows don't seem to vanish
after visiting the circus (note however that old savegames
will still be affected). For MI2 though there are still no
verb shadows, even in a newly started game.

comment:6 by fingolfin, 17 years ago

Component: --Unset--Engine: SCUMM
Game: Monkey Island 2
Summary: Verbs shadows missing in MI1&2MI2: Verbs shadows missing

comment:7 by fingolfin, 17 years ago

Changing bug title & group as this only seems to be affecting
Monkey Island 2 anymore, MI1 seems to work fine.

by SF/logicdeluxe, 17 years ago

Attachment: monkey.s02 added

comment:8 by SF/logicdeluxe, 17 years ago

Built on Aug 4 2002 23:33:41
The shadows still turn to black in MI1 after I become shot
out of the cannon in MI1. This was as I filed that bug and
so it remains. In case you misunderstood, it didn't happen
when you just enter the tent and leave it again. It happens
not until you will be shot out of the cannon. I attach a
savegame in front of the tent. Try entering and leaving the
tent with and without the money!

comment:9 by eriktorbjorn, 17 years ago

Ironically, Monkey2's verb shadows were working as early as
ScummVM 0.0.1, and this part of the code doesn't appear to
have changed that much since then.

If I remove the line

memset(_charsetData, 0, sizeof(_charsetData));

from loadCharset(), it will work (though not with old
savegames since _charsetData is stored in them), and I
honestly don't see why loading one charset should wipe out
the entire _charsetData array.

The line was added in revision 1.62 of resource.cpp to "Fix
charset background problem in VC". Could anyone elaborate on
that? Would it be enough to clear _charsetData just once in
scummInit()?

comment:10 by SF/ender, 17 years ago

Yes, just doing this on initial init of the array is more than enough.

comment:11 by eriktorbjorn, 17 years ago

Very well, then. If it hasn't been fixed by tomorrow, I'll
submit a patch. (The one I had prepared - but not submitted
- for today only did half the job. :-)

comment:12 by SF/ender, 17 years ago

Fixed by ereiktorbjorn's patch (new games only)

comment:13 by SF/ender, 17 years ago

Owner: set to SF/ender
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.