Opened 15 years ago

Closed 15 years ago

#1985 closed defect (fixed)

FM-TOWNS LOOM: Multiple text lines spacing incorrect

Reported by: SF/celemar Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

In the April 4 2005 daily build of ScummVM I noticed
something that seemed to be a bug in Loom FM Towns.

When more than one line of dialogue is displayed,
between the lines are one pixel of shading from the top
row of letters and one row of empty space. The "empty
space pixel row" should not be there. The original
interpreter did not have it, nor was it in earlier
versions of ScummVM.

The problem was not present in the 27 February 2005
daily build. I am using Windows XP, for the record, and
the English version of the game.

I can see that this might have been done deliberately,
to make the text easier to read, but I'd like the game
to conform as much to the original interpreter's
methods as possible. Thanks.

Ticket imported from: #1177489. Ticket imported from: bugs/1985.

Change History (2)

comment:1 by Kirben, 15 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:2 by Kirben, 15 years ago

I added support for the string height setting in Loom [ega] not
long ago and that is the cause of the problem.
I checked the code of original Loom [FM Towns] and the
string height setting is just ignored, so I altered ScummVM to
ignore the setting for FM Towns versions of games.

Note: See TracTickets for help on using tickets.