Opened 16 years ago

Closed 16 years ago

Last modified 23 months ago

#1979 closed defect (fixed)

Slight mouse cursor regression

Reported by: eriktorbjorn Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

I'm not sure if this is a bug or a feature, but...

In ScummVM 0.7.x, when the screen shakes (e.g. when listening to Green Tentacle's stereo in Day of the Tentacle), the mouse cursor shakes with the rest of the image.

In the current development version of ScummVM, the mouse cursor remains steady.

Ticket imported from: #1173422. Ticket imported from: bugs/1979.

Change History (5)

comment:1 by eriktorbjorn, 16 years ago

Owner: set to sev-

comment:2 by eriktorbjorn, 16 years ago

I'm guessing it's related to the recent mouse cursor changes.

comment:3 by sev-, 16 years ago

Indeed, it is because cursor now is rendered on a separate surface.

Fixed.

comment:4 by sev-, 16 years ago

Resolution: fixed
Status: newclosed

comment:5 by digitall, 23 months ago

Component: --Unset--Engine: SCUMM
Game: Day of the Tentacle
Note: See TracTickets for help on using tickets.