Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1963 closed defect (duplicate)

BASS: Locked characters + interaction = freeze

Reported by: SF/firebrand459 Owned by: lavosspawn
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

ScummVM Version: 0.7.0 and 0.8.0CVS

Language: (default) which I believe is english UK

Version: Talkie

Platform: (slight confusion): Running on windows '00, within the program, platform is set to default

Save file attached. Save is in the bar, with the barman frozen.

So, I've discovered the body of Anita and retrieved her keycard. I had a save at this point and tried numerous different combinations of talking to and not talking to specific people, but every time I go to the club, the barman is frozen. Everything else works fine, but he exhibits no motion at all. Interacting with anything else in the room is fine, leaving and re-entering is fine, but the barman is still locked. If I make any attempt to interact with him (talking or using an item on him) the game stops. All other characters and background animations continue as normal, but the cursor disappears and my character stands there waiting for a response that never comes. I can use f5 to access my save menu, but that is the extant of what I can do. I saw a similar report about the gardener, but nothing about the barman, so I figured I'd throw this in.

Ticket imported from: #1166890. Ticket imported from: bugs/1963.

Attachments (1)

SKY-VM.002 (14.3 KB ) - added by SF/firebrand459 15 years ago.
In the bar, barman frozen. Talk to him to lock the game.

Download all attachments as: .zip

Change History (9)

by SF/firebrand459, 15 years ago

Attachment: SKY-VM.002 added

In the bar, barman frozen. Talk to him to lock the game.

comment:1 by eriktorbjorn, 15 years ago

Owner: set to lavosspawn

comment:2 by joostp, 15 years ago

Summary: Locked characters + interaction = freezeBASS: Locked characters + interaction = freeze

comment:3 by joostp, 15 years ago

Thanks for reporting. This does indeed sound very similar to the gardener lock up and is caused by buggy games scripts. It would be trivial to hack around this in the engine, like we did for the gardener.. I'll leave that decision up to LavosSpawn though.

For now, you can do a: "logiccmd fn_send_sync 16701 1" from the debugger (enter it with the "`" or "~" key) to unfreeze the barman.

comment:4 by fingolfin, 15 years ago

Component: Engine: Sky
Game: Beneath a Steel Sky

comment:5 by fingolfin, 15 years ago

Component: Engine: Sky
Game: Beneath a Steel Sky

comment:6 by fingolfin, 15 years ago

See also bugs #1097997 and #1106347 were similiar lock ups are described (at least they sound similiar to me). And the gardner apparently still causes lock ups, according to these reports?

comment:7 by fingolfin, 15 years ago

To clarify this: There were a total of apparently similar bug reports. - #1106347 - #1166890 - #1097997

I only leave #1097997 open, as it is the oldest of the three. Please add any further information to that bug report only.

comment:8 by fingolfin, 15 years ago

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.