Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1938 closed defect (invalid)

Windows/BASS: crash when no soundcard present

Reported by: SF/clemty Owned by: Kirben
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

using 0.7.0 on Windows XP - a user wrote me about his BASS installation not working - turned out there's a fatal error if windows can't open sound output.

(to reproduce: if you have an onboard soundcard disable it in the BIOS, then try to launch BASS)

seems to only occur on windows, joostp (I think) on IRC couldn't reproduce it

only seems to occur with BASS - FOTAQ and BS1 give warning but run anyways

clem

PS: in queen the error is: WARNING: Sound initialisation failed.! in bass it is: WARNING: Sound initialisation failed!

you might consider removing that typo 'dot' in Queen's error msg

Ticket imported from: #1149917. Ticket imported from: bugs/1938.

Attachments (1)

basscrash.txt (913 bytes ) - added by SF/clemty 15 years ago.
cmd.exe output of errors

Download all attachments as: .zip

Change History (7)

by SF/clemty, 15 years ago

Attachment: basscrash.txt added

cmd.exe output of errors

comment:1 by SF/olki, 15 years ago

Component: Engine: Sky
Game: Beneath a Steel Sky

comment:2 by SF/clemty, 15 years ago

see attached basscrash.txt; here's what the guy sent me via mail (he said he removed his soundcard some time ago): ------------------------------------------------------- Looking for sky Trying to start game "beneath a steel sky" WARNING: Sound initialisation failed! Found BASS version v0.0348 <1445 dnr entries> WARNING: MM system error ' a device ID has been that is out of ange for your system!

Cant open Midi device. Errorcode: 3! -------------------------------------------------------

comment:3 by Kirben, 15 years ago

Use the null music driver, ie: scummvm -enull sky

comment:4 by Kirben, 15 years ago

Owner: set to Kirben
Resolution: invalid
Status: newclosed

comment:5 by SF/clemty, 15 years ago

yeah we figured so much. still doesn't explain why FOTAQ runs though (BS1 might be debatable since it doesn't seem to use midi)

comment:6 by fingolfin, 15 years ago

Component: Engine: Sky
Game: Beneath a Steel Sky
Note: See TracTickets for help on using tickets.