Opened 15 years ago

Closed 15 years ago

#1933 closed defect (duplicate)

MI1: Game crashes when the church in town is entered.

Reported by: SF/chronozaga Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

Game crashes when the church in town is entered, making it not completeable. Game crashes and ScummVM shows the following debug information.

ERROR: Gdi::decompressBitmap: default case 6

Sound like it could be a problem with my copy of Monkey Island being corrupt, but when I run the game with it's original executable, rather than through ScummVM, I can enter the church.

Ticket imported from: #1144865. Ticket imported from: bugs/1933.

Attachments (1)

monkeyVGA.s01 (7.9 KB ) - added by SF/chronozaga 15 years ago.
crash-ready save game

Download all attachments as: .zip

Change History (8)

comment:1 by sev-, 15 years ago

To process your bug report appropriately, we need you to provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build) * Bug details, including instructions on reproducing it * Language of game (English, German, ...) * Version of game (talkie, floppy, ...) * Platform and Compiler (Win32, Linux, MacOS, ...) * Attach a save game if possible * If this bug only occurred recently, please note the last version without the bug, and the first version including the bug. That way we can fix it quicker by looking at the changes made.

This should only take you a little time but will make it much easier for us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by sev-, 15 years ago

Summary: Game crashes when the church in town is entered.MI1: Game crashes when the church in town is entered.

by SF/chronozaga, 15 years ago

Attachment: monkeyVGA.s01 added

crash-ready save game

comment:3 by SF/chronozaga, 15 years ago

Issue is with BOTH version 0.7.0 and the latest CVS build "Win32 Daily Snapshot (1409K exe file, last update: February 19, 2005, 7:52 pm)"

Game version is the VGA floppy English version

Simply walk into the church in the attached save game to duplicate.

comment:4 by eriktorbjorn, 15 years ago

I can reproduce the crash. At least with this savegame:

#0 Scumm::Gdi::decompressBitmap(unsigned char*, int, unsigned char const*, int) (this=0x1d70270, dst=0x26a1344 "ccddeeffgghhijkjklljcdcdefdghhiijjkiiklifgijlncdcffhijkl\201\201\201\201\201\200\200", dstPitch=320, src=0x519561a <Address 0x519561a out of bounds>, numLinesToProcess=144) at scumm/gfx.cpp:1611 #1 0x0045cc8e in Scumm::Gdi::drawBitmap(unsigned char const*, Scumm::VirtScreen*, int, int, int, int, int, int, unsigned char, Scumm::StripTable*) ( this=0x1d70270, ptr=0x1e50ccb "\b", vs=0x1d78aa4, x=0, y=0, width=24, height=144, stripnr=0, numstrip=3, flag=0 '\0', table=0x0) at common/scummsys.h:354 #2 0x00498d93 in Scumm::ScummEngine::drawObject(int, int) (this=0x1d70210, obj=1, arg=0) at scumm/object.cpp:488 #3 0x004989db in Scumm::ScummEngine::drawRoomObject(int, int) ( this=0x1d70210, i=1, arg=0) at scumm/object.cpp:377 #4 0x00498ab2 in Scumm::ScummEngine::drawRoomObjects(int) (this=0x1d70210, arg=0) at scumm/object.cpp:395 #5 0x0045b40d in Scumm::ScummEngine::redrawBGAreas() (this=0x1d70210) at scumm/gfx.cpp:738 #6 0x0042149a in Scumm::ScummEngine::scummLoop(int) (this=0x1d70210, delta=6) at scumm/scumm.cpp:1839 #7 0x004204e5 in Scumm::ScummEngine::go() (this=0x1d70210) at scumm/scumm.cpp:1599 #8 0x004083d7 in runGame(GameDetector&, OSystem&) (detector=@0x22ff28, system=@0x1d6c840) at base/main.cpp:277 #9 0x00408e71 in main (argc=4, argv=0x3f25c8) at base/main.cpp:407

So apparently it crashes when trying to draw a room object.

comment:5 by eriktorbjorn, 15 years ago

However, if I use a bootparam (e.g. 8889) to skip to shortly before the wedding, ScummVM does not crash when I enter the church.

comment:6 by fingolfin, 15 years ago

Owner: set to fingolfin
Resolution: duplicate
Status: newclosed

comment:7 by fingolfin, 15 years ago

This is a duplicate of bug #795214.

(Sadly I don't have the english version of MonkeyVGA)

Note: See TracTickets for help on using tickets.