Opened 14 years ago

Closed 14 years ago

Last modified 7 months ago

#1921 closed defect (fixed)

PALM: ScummVM breaks auto-off

Reported by: SF/kno1 Owned by: SF/chrilith
Priority: normal Component: Port: PalmOS
Keywords: Cc:
Game:

Description

After running ScummVM on a palm (a Tungsten T3 in this
case) en exiting, the Palm will no longer auto power off, if
it is configured to do so. Only after a reset will the auto
power off work again.

What I did to check this:
- reset
- configure auto off
- wait until palm powers off
- turn palm on again
- start scummcm
- start Indiana Jones and the fate of atlantis.
- quit scummvm
- wait and you'll notice the palm won't power off.

I haven't tried just starting scummvm and exiting without
starting a game.

The bug might not sound too serious, but it's a pain if
you have a nightly backup scheduled and discover in the
morning you've now got a flat battery...

Ticket imported from: #1118502. Ticket imported from: bugs/1921.

Change History (10)

comment:1 Changed 14 years ago by fingolfin

Owner: set to SF/chrilith

comment:2 Changed 14 years ago by fingolfin

Chrilith, if you have some time, please comment, too :-)

comment:3 Changed 14 years ago by fingolfin

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:4 Changed 14 years ago by SF/kno1

The ScummVM version I use is from 2004-12-24,
version 0.7.0, for PalmOS.

The game language was english and it was the talkie/cd
version of the game.

Savegame is not needed.

Unfortunately, lately I haven't been able to run scummvm on
my T3 at all. It hangs immediatelly, (it looks like the front-end
hangs). And I haven't felt like doing a hard reset and
reinstalling everything yet. This also means I can't test a CVS
build, even if I'd known where to get it...

Remco
I don't have access to nightly builds, and the latest test
version from the ho

comment:5 Changed 14 years ago by SF/chrilith

Hi,

This bug has been fixed locally.
I need to make some cleanup and i'll update the CVS with
many changes, including this fix.

Thanks

comment:6 Changed 14 years ago by sev-

What is the status of this item?

comment:7 Changed 14 years ago by SF/chrilith

Status: newclosed

comment:8 Changed 14 years ago by SF/chrilith

This has been fixed locally. Closed.

comment:9 Changed 14 years ago by SF/chrilith

Resolution: fixed

comment:10 Changed 7 months ago by digitall

Component: --Unset--Port: PalmOS
Note: See TracTickets for help on using tickets.