Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1912 closed defect (duplicate)

Crash when you enter the church

Reported by: SF/ruloner Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

Here are the details:

Scumm Version: 0.7.0

Error displayed: "Error: GDI::decompressbitmap: default case 0"

Near the end of the game, when you have to enter the church to stop it, the console comes up and the game crashes, telling me the message above.

Language: Spanish

Version: 256 Color floppy version

Platform: PocketPC

I've included the error log at the end of this post and the savegame. Thanks a lot in advance...

PD: Great work with this program, keep it up!

Crash Log ---------------------------------------- Exception Access Violation Flags 00000000 Address 000c728c Parameter 0 00000000 Parameter 1 0388fd92 ---------------------------------------- Context dump R0=00404180 R1=00518714 R2=00000140 R3=0388fd92 R4=00404180 R5=00000000 R6=00518714 R7=00000140 R8=00000090 R9=00000090 R10=004100d8 R11=00000000 R12=1e3bf8a8 Sp=1e3bf7f4 Lr=000c6770 Pc=000c728c Psr=2000001f ---------------------------------------- Memory dump at 000c725a 82 e3 e6 5c fe ea 40 f3 24 00 10 f3 24 00 f0 8c bd e8 f0 4f 2d e9 0c d0 4d e2 30 80 9d e5 00 40 a0 e1 01 60 a0 e1 02 70 a0 e1 00 00 58 e3 c9 00 00 0a 00 90 d3 e5 00 a0 a0 e3 01 50 83 e2 0a b0 a0 e1 0a 00 59 e3 4d 00 00 8a 01 00 49 e2 09 00 50 e3 00 f1 8f 90 45 00 00 ea 08 00 00 ea 0e 00 00 ea 14 00

Ticket imported from: #1113116. Ticket imported from: bugs/1912.

Attachments (1)

monkeyVGA.s01 (7.7 KB ) - added by SF/ruloner 16 years ago.
Saved in front of the church, enter it to see the error

Download all attachments as: .zip

Change History (4)

by SF/ruloner, 16 years ago

Attachment: monkeyVGA.s01 added

Saved in front of the church, enter it to see the error

comment:1 by fingolfin, 16 years ago

Status: newclosed

comment:2 by fingolfin, 16 years ago

Resolution: duplicate

comment:3 by fingolfin, 16 years ago

Sounds like a duplicate of this (still open) bug report: <https:// sourceforge.net/tracker/? group_id=37116&atid=418820&func=detail&aid=795214>. Feel free to add you case with your details to that report. Thanks!

Note: See TracTickets for help on using tickets.