Opened 15 years ago

Closed 15 years ago

Last modified 13 months ago

#1895 closed defect

PALM: fatal alert on Zire71

Reported by: SF/godzer Owned by: SF/chrilith
Priority: high Component: Port: PalmOS
Keywords: Cc:
Game:

Description

in the palm of scummVM version 0.7 the game seems to
function perfectly. But after a short time (the time
varies) the
Palm displayes a "Faltal error:"

"MemoryMgr.c, Line:2757, MemMove to NULL"

and then it locks up.

I tried it on a "blank" Palm with over 12.5mb of free
memory and no other programs installed with no luck.

The bug is in all games i have tried.

Thanks for a great program!

Ticket imported from: #1102722. Ticket imported from: bugs/1895.

Change History (18)

comment:1 by fingolfin, 15 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by fingolfin, 15 years ago

Owner: set to SF/chrilith
Status: newpending
Summary: fatal alert on Zire71PALM: fatal alert on Zire71

comment:3 by SF/godzer, 15 years ago

Version when problem started: v0.7.x
Last working version: v0.6.x
the problem is present in all scummVM games (to my knowledge)
the problem is on a PalmOS 5 device Zire 71

comment:4 by SF/godzer, 15 years ago

Status: pendingnew

comment:5 by SF/godzer, 15 years ago

Priority: normalhigh

comment:6 by SF/chrilith, 15 years ago

you're talking about storage memory not dynamic memory.
Please give me the amount of free dynamic memory.

comment:7 by SF/godzer, 15 years ago

The Zire 71 has 1024 (1 MegaByte) of dynamic memory (heap)

comment:8 by SF/godzer, 15 years ago

by the way.. i tried useing UDMH (program for getting
unlimited amount of dynamic memory heap) and it worked..
hope you fix the issue anyway. we dont want the users to
have to bye a 3rd party program to use this great program

comment:9 by SF/chrilith, 15 years ago

Status: newclosed

comment:10 by SF/chrilith, 15 years ago

Wow... this seems to be THE soft to have ... can you send
me a link i can give to all other users having the same
problem ?

Thanks

comment:11 by SF/godzer, 15 years ago

http://dmitrygr.titaniumhosting.com/articles.php?pg=69

this is a great little program.. but i hope you fix scummVM
so i is possible to run on systems with less dynamic
memory.. Would not want to tell people that they have to buy
this program to run a another free program ;)

thanks for a great program btw

comment:12 by SF/godzer, 15 years ago

Status: closednew

comment:13 by SF/kuroshima, 15 years ago

I have the same prblem with ScummVM in my Zire71 playing
Monkey Island 2
ScummVM Version: 7.0 (Also happens with 8.0CSV)
Once the game finishes loading, if I press any part of the
screen, I get:
"Faltal error:"
"MemoryMgr.c, Line:2757, MemMove to NULL"
Language of the game: Spanish
Game for: PC (CD version)
Works fine with ScummVM 6.1

comment:14 by fingolfin, 15 years ago

Chrilith, care to comment?

I think this thing is asked so often, couldn't we add an entry to the FAQ for
it?

comment:15 by SF/chrilith, 15 years ago

Yes sure fingolfin

comment:16 by SF/chrilith, 15 years ago

This is a memory issue. Palm devices have commonly 2
types of memory : dynamic and storage. The storage
memory is the one you see on the palm info panel
(applications, memory usage, ...), has a protected access
and cannot be used in project like ScummVM unless we
rewrite many parts of the code. The dynamic one is the
memory you can allocate for direct access, the one used in
ScummVM. This memory can be very limited mainly on
PalmOne devices (Tungsten|T, T2, Zire71, ...) and depending
on the game/engine you want to use, ScummVM may crash
with a "MemoryMgr.c, Line:2757, MemMove to NULL" or any
other errors related to memory. There is no simple way to fix
this but you can use a Palm application called UDMH which
provide you a way to change the amount of free dynamic
memory.
UDMH : http://dmitrygr.titaniumhosting.com/

Closed.

comment:17 by SF/chrilith, 15 years ago

Status: newclosed

comment:18 by digitall, 13 months ago

Component: Port: PalmOS
Note: See TracTickets for help on using tickets.