Opened 15 years ago

Closed 15 years ago

Last modified 11 months ago

#1883 closed defect (wontfix)

FLAC not detected in Mandrake 10.1

Reported by: SF/jellby Owned by: fingolfin
Priority: normal Component: Port: Linux
Keywords: Cc:
Game:

Description

I have an almost fresh install of a Mandrake 10.1 system, I installed the
package libflac6-devel, but still flac was not detected by the configure
script and if forced to use it, there would be an error in the compilation.
(jan-7 cvs and previous)

I found the problem is solved by defining HAVE_INTTYPES_H, so by using
the command line:

$ CXXFLAGS=-DHAVE_INTTYPES_H ./configure

I could compile everything without problems.

I don't know exactly why this definition is needed, but maybe the
configure script coul be modified to include it or to detect when it is
needed.

Ticket imported from: #1098857. Ticket imported from: bugs/1883.

Change History (3)

comment:1 by fingolfin, 15 years ago

Sounds like a mandrake specific bug. FLAC needs inttypes.h,
and should normally always include, no matter what value
HAVE_INTTYPES_H has. In fact I just checked, and neither
ScummVM nor the FLAC headers use that HAVE_INTTYPES_H.

So it appears mandrake ships a broken system. I recommend
filing a bug report with them.

comment:2 by fingolfin, 15 years ago

Owner: set to fingolfin
Resolution: wontfix
Status: newclosed

comment:3 by digitall, 11 months ago

Component: --Unset--Port: Linux
Note: See TracTickets for help on using tickets.