Opened 15 years ago

Closed 15 years ago

Last modified 18 months ago

#1873 closed defect (fixed)

INDY3 FMTOWNS: Music in Venice is distorted

Reported by: SF/isaac_a_steiner Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

The Midi Music in Venice is heavily distorted.
(didn't play any further)

Using ScummVM 0.7.0

Thank you,
Isaac

Ticket imported from: #1096742. Ticket imported from: bugs/1873.

Change History (10)

comment:1 by fingolfin, 15 years ago

It works great over here... are you sure it is distorted? I.e. have you
ever listened to the "real" thing as comparision? It does sound somewhat
"bizarre", but that's intentional...

comment:2 by fingolfin, 15 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed
Summary: Indy3TownsINDY3 FMTOWNS: Music in Venice is distorted

comment:3 by fingolfin, 15 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:4 by Kirben, 15 years ago

Owner: fingolfin removed
Resolution: worksforme
Status: closednew

comment:5 by Kirben, 15 years ago

I recently looked over disasm. of FM Towns versions of
indy3towns and only sound types 0 - 2 are actually used.
Any other sound type value is just ignored, so the sound is
never played.

The sound resource (40) used for the music in Venice uses a
sound type of 255, and is the only sound resource to use that
sound type. I wonder if we should be playing this music at all.

The other three sound resources (29, 54, 66) used for music
in indy3towns all have the correct sound type (1) and don't
sound too bad.

So re-opening this bug report, until someone can check this
issue in original game.

comment:6 by fingolfin, 15 years ago

Status: newclosed

comment:7 by fingolfin, 15 years ago

Setting this to pending. It's pointless to keep this report until somebody
checks (using an original FM-TOWNS or maybe an emulator) what should
actually happen in this scene).

comment:8 by Kirben, 14 years ago

Owner: set to Kirben
Resolution: fixed

comment:9 by Kirben, 14 years ago

I just played through some of the original game under UNZ,
the Venice music is never played under UNZ.
I played as far as the room with the wodden plug under UNZ,
to be sure that the music (ie Indiana theme) does work under
UNZ.

Fixed in ScummVM CVS, we match the three sound types of
the original game now.

comment:10 by bonki, 18 months ago

#10561 is a duplicate of this (sort of).

Note: See TracTickets for help on using tickets.