Opened 15 years ago

Closed 15 years ago

#1858 closed defect (fixed)

DIG: Starting new games takes a long time (regression)

Reported by: fingolfin Owned by: fingolfin
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

I just noticed that with latest CVS, and also with ScummVM 0.7.0,
starting a new game of The Dig, that is, typing:
./scummvm dig
takes a very long time. More specifically, from the point the
ScummVM window opens (with black content) until the intro movie
of The Dig starts, 10-12 seconds pass. With 0.6.1b, the movie
starts almost instantly.

Ticket imported from: #1091748. Ticket imported from: bugs/1858.

Change History (7)

comment:1 by fingolfin, 15 years ago

I just run Dig with -x7, and noticed that during the "hang" we see a lot of

Locking mutex IMuseDigital::callback()
Unlocking mutex IMuseDigital::callback()
Locking mutex IMuseDigital::callback()
Unlocking mutex IMuseDigital::callback()
...

Maybe this issue is related to iMuseDigital in some way? This is
just a wild guess, I see no strong reason to believe it, but right
now I can't think of anything...
aquadran, maybe you have an idea?

comment:2 by fingolfin, 15 years ago

Owner: set to aquadran

comment:3 by aquadran, 15 years ago

i can't reproduce it.
"Locking mutex IMuseDigital::callback()
Unlocking mutex IMuseDigital::callback()" that is normal for
whole game, callback 10 times per second.

comment:4 by sev-, 15 years ago

Easily reproduceable here, though delay is about 8 seconds
here, maybe due to faster computer. It loops in script 149
by that time, though. Processor load is 100%.

comment:5 by aquadran, 15 years ago

bug is introduced by patch fix to another bug :)
http://cvs.sourceforge.net/viewcvs.py/scummvm/scummvm/scumm/debugger.cpp?r1=1.135&r2=1.136

comment:6 by fingolfin, 15 years ago

Owner: changed from aquadran to fingolfin
Resolution: fixed
Status: newclosed

comment:7 by fingolfin, 15 years ago

Thanks for the help, aquadran. Fixed in CVS now.

Note: See TracTickets for help on using tickets.