Opened 16 years ago

Closed 16 years ago

Last modified 13 months ago

#1839 closed defect (fixed)

MM V2 (German): incorrect text presentation

Reported by: SF/martingu Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

game: maniac manson v2 german pc on win32 scummvm version: 8.12.2004

after being imprisoned by weird ed (just load the savegame and take the hamster) you are taken to prison and ed says: "Schade, daß du nicht auf meiner Seite bist". the text should be presented in 2 lines, but the end of the text is printed in the first line as well and printed over the first part. bug also appeared in daily build from december 6th, 2004.

besides that I have played through the whole game and found no other bugs. so I think you could consider this game as tested for 0.7 release.

Ticket imported from: #1082154. Ticket imported from: bugs/1839.

Attachments (3)

maniac.s01 (4.3 KB ) - added by SF/martingu 16 years ago.
just load and take the hamster
text bug.JPG (62.0 KB ) - added by SF/martingu 16 years ago.
screenshot
wordwrap.jpg (48.8 KB ) - added by SF/martingu 16 years ago.
screenshot of original game engine

Download all attachments as: .zip

Change History (13)

by SF/martingu, 16 years ago

Attachment: maniac.s01 added

just load and take the hamster

by SF/martingu, 16 years ago

Attachment: text bug.JPG added

screenshot

comment:1 by sev-, 16 years ago

Summary: incorrect text presentationMM ench (German): incorrect text presentation

comment:2 by sev-, 16 years ago

I updated release testing information

comment:3 by sev-, 16 years ago

Summary: MM ench (German): incorrect text presentationMM V2 (German): incorrect text presentation

comment:4 by fingolfin, 16 years ago

Interesting. In newer SCUMM games, text is wrapped by the engine, but so far we believed that V1-V3 games didn't do this. See string.cpp, lines 203 and 204:

if (_version > 3) _charset->addLinebreaks(0, buffer, 0, t);

We can't just call addLinebreaks, though, because it would wrap to much -- but maybe we can add a special addLinebreaks version for old games...

*IF* the problem is that we are not doing custom wrapping. Maybe something else is wrong :-)

comment:5 by fingolfin, 16 years ago

Any chance somebody could test this with the original engine (that would probably require playing with the original engine up to that point), and tell me what it does: * do a word wrap (i.e. display "bist." in the next line) * do a char wrap (i.e. display "bi" in the first line, and "st." in the second line * do something else (what?) Ideally, a screenshot of the original would be cool.

by SF/martingu, 16 years ago

Attachment: wordwrap.jpg added

screenshot of original game engine

comment:6 by SF/martingu, 16 years ago

here we go...

comment:7 by SF/martingu, 16 years ago

incomplete previous post, sorry

screenshot of original engine added with previous post. shows how buggy scummvm-wordwrap is handled in original game engine

comment:8 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:9 by fingolfin, 16 years ago

Thanks a bunch, martingu, that helped a lot.

Fixed in CVS.

comment:10 by Peter Kohaut <peterkohaut@…>, 13 months ago

Last edited 13 months ago by criezy (previous) (diff)
Note: See TracTickets for help on using tickets.