Opened 15 years ago

Closed 15 years ago

Last modified 11 months ago

#1838 closed defect (fixed)

GUI: ScummVM returns to window mode automatically

Reported by: SF/trinity78 Owned by: fingolfin
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

ScummVM Daily Build (8. December)
Windows 2000 SP4

When trying to start a game in full screen mode,
ScummVM automatically returns to window mode.

To reproduce this bug:

1.) start scummvm without any parameters in window mode
2.) switch to full screen mode (alt + enter)
3.) launch any game

After you have launched a game, ScummVM returns to
window mode.

This might bug might be releated to the "full screen"
bug submitted some days ago.

Propably not related:

If you use the quit-button from the ingame menu (F5 -
key), ScummVM quits instead of returning to the
launcher menu. Don't know if this is intended.

Ticket imported from: #1082105. Ticket imported from: bugs/1838.

Change History (8)

comment:1 by SF/trinity78, 15 years ago

Summary: Gui: ScummVM returns to window mode automticallyGui: ScummVM returns to window mode automatically

comment:2 by sev-, 15 years ago

Owner: set to sev-

comment:3 by sev-, 15 years ago

Yes, they are closely related. Will have time to fix it in a
week.

comment:4 by cyxx, 15 years ago

I don't think this related at all with the previous report.
Moreover, this was present in 0.6.1b too. And we have the
same behaviour with ARC...

If we must change something to fix that, we should look at
Engine::initCommonGFX, where we setup the screen accordingly
to the config settings, without considering the current
screen "state".

But, should we really fix this behaviour ? Afterall,
shouldn't the config manager override the backend settings ?

comment:5 by fingolfin, 15 years ago

Component: --Unset--
Summary: Gui: ScummVM returns to window mode automaticallyGUI: ScummVM returns to window mode automatically

comment:6 by fingolfin, 15 years ago

Owner: changed from sev- to fingolfin
Resolution: fixed
Status: newclosed

comment:7 by fingolfin, 15 years ago

Fixed in CVS.

Oh and yes, "quit" quits ScummVM, as it should. The hack that
was in there for some time which changed the behaviour to
instead return to the launcher was disabled again recently.

comment:8 by digitall, 11 months ago

Component: --Unset--GUI
Note: See TracTickets for help on using tickets.