Opened 15 years ago

Closed 15 years ago

Last modified 8 months ago

#1836 closed defect (invalid)

ALL: Sound is out of sync

Reported by: SF/noltec Owned by: fingolfin
Priority: normal Component: Audio
Keywords: Cc:
Game:

Description

Voice output and SFX is out of sync. The sound comes a
half of a second to early. This is true for cut-scenes
and during the game. Is it somehow possible to change
the sound-sync of the game?

-------------------------
ScummVM 0.6.1b (Nov 24 2004 21:49:33)
Features compiled in: Vorbis MP3 ALSA zLib MPEG2

Language: German
Version: CD
Platform: Linux localhost 2.6.9-1.681_FC3 #1 Thu Nov 18
15:10:10 EST 2004 i686 athlon i386 GNU/Linux
Sound-Output-Method: ALSA

Ticket imported from: #1078366. Ticket imported from: bugs/1836.

Change History (12)

comment:1 Changed 15 years ago by SF/noltec

Component: Engine: SCUMM--Unset--
Game: Monkey Island 3
Priority: normalhigh
Summary: COMI: Sound is out of syncSound is out of sync

comment:2 Changed 15 years ago by SF/noltec

Originally I have only tested it with COMI. The same issue
occurs with other games as well:

- Day Of The Tentacle (German - talkie)
- Indiana Jones Fate of Atlantis (English - talkie)
- Sam and Max (English - talkie)

The sound-output (Music and SFX) comes about a second to
early and is not "lip-sync" with the actors talking.

comment:3 Changed 15 years ago by SF/noltec

Summary: Sound is out of syncALL: Sound is out of sync

comment:4 Changed 15 years ago by fingolfin

please don't mess with our tracker item priorites, they are for internal
use only. We decide what we deem important and what not...

Anyway: I can't reproduce the problem here (on an Mac OS X machine)
at all, with none of the games you mention.
It may simply be a problem with your local sound setup.

comment:5 Changed 15 years ago by fingolfin

Priority: highnormal
Resolution: worksforme

comment:6 Changed 15 years ago by eriktorbjorn

It's strange that he gets the sound too early, though. I've
heard people complaining about the sound coming too late -
usually as a result of some sound daemon holding things up -
but too early... that's a first.

comment:7 Changed 15 years ago by SF/noltec

Sorry for messing with the tracker, I did not intend to
confuse anybody...

I have to apologize for another thing: the sound does *not*
come to early, as stated by me, it comes too late. (sorry
about that!) I will check my sound-configuration further.

Some details of my configuration:
ALSA ver. 1.0.6 (I will try it with 1.0.7 soon)
SoundBlaster Audigy Player (emu10k)

What I have already noticed was the software-emulation of
the midi-sound (adlib) which scummvm did because of a
missing synth device. I have fixed this. Midi-synth is now
done in Hardware. This improved the synchronicity with the
midi-based sfx. Speech still is out of sync (it comes too
late). I'll check that later!

comment:8 Changed 15 years ago by SF/noltec

The sollution is as follows:

I am using KDE 3.3.1 an disabling the artsd solves this
issue. Does anyone know how to configure the artsd
correctly? I have tried every setting with no effect. The
only thing I can do is to disable it completely. Could this
be a bug in artsd? All other sound-apps work fine without a
problem (with artsd enabled).

comment:9 Changed 15 years ago by fingolfin

Thanks for the feedback, noltec.

Problems with artsd, that's a problem we've encountered before.
As I understand it, the problem is that artsd simply has a
relatively high latency (being a sound server process, and such);
in most programs (like a MP3 player) you simply don't notice this
because you have no graphic reference to compare to. As such,
it's probably not a "bug" in artsd, but more a design problem.

comment:10 Changed 15 years ago by fingolfin

Owner: set to fingolfin
Resolution: worksformeinvalid
Status: newclosed

comment:11 Changed 15 years ago by SF/noltec

Hmmm...

For a mp3-player this would be true, but I use mplayer to
play my video files (also through alsa) and there are no
such issues with video/sound sync. Could it be that the
mplayer goes directly on the alsa library with bypassing
artsd? If so, would it be possible to implement the
alsa-sound layer in scummvm so that it bypasses an enabled
sound-server (artsd, esd,...)?

comment:12 Changed 8 months ago by digitall

Component: --Unset--Audio
Note: See TracTickets for help on using tickets.