Opened 15 years ago

Closed 15 years ago

Last modified 10 months ago

#1785 closed defect (fixed)

ALL: Transition FX not working anymore

Reported by: fingolfin Owned by: fingolfin
Priority: high Component: Graphics
Keywords: Cc:
Game: The Dig

Description

I just noticed that most (all?) of the graphic transitions (opening/
closing iris etc.) stopped working in latest CVS. I confirmed this in
The Dig and Monkey Island I, but I guess other are affected, too.

My guess is that I broke this during my recent smooth scrolling
changes, though I dunno how I may have pulled that feat ;-). And
maybe I am wrong, and something else is responsible, so watch
out...

I am too tired to look into this myself now -- everybody feel free
to have a go at this one :-)

Ticket imported from: #1035184. Ticket imported from: bugs/1785.

Change History (6)

comment:1 Changed 15 years ago by eriktorbjorn

Some of the transitions work. The scroll effect seems to
work - at least with one of my old savegames - and the iris
effect is sort-of working in Maniac Mansion, but the center
point seems to be off.

But there are plenty of other regressions. I've already
filed a bug report about the MM v1 intro, and I just noticed
that the DOTT inventory isn't drawn! I'll file a bug report
about that right away.

comment:2 Changed 15 years ago by eriktorbjorn

The "other regressions" turned out to be unrelated.

comment:3 Changed 15 years ago by eriktorbjorn

I'm getting the impression that something is causing the
screen to be redrawn all at once before the transition
effect gets to do it gradually. I tried modifying the
drawStripToScreen() function to draw random data to the
screen instead, and then I could see something at least
vaguely transition-effectish.

However, just like with Maniac Mansion, the center point
seemed to be wrong, so there may be two different bugs here.
I haven't managed to figure out any of them yet, though.

comment:4 Changed 15 years ago by fingolfin

Found it. From gfx.cpp:

if (width > vs->w - x);
width = vs->w - x;

count the semicolons :-)

comment:5 Changed 15 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:6 Changed 10 months ago by digitall

Component: --Unset--Graphics
Game: The Dig
Note: See TracTickets for help on using tickets.