Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1778 closed defect (fixed)

INDY3-VGA: actors walking in wrong places

Reported by: SF/tobybear Owned by: fingolfin
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

Game: Indy 3 VGA, DOS, English
Tested with: ScummVM 0.6.1b + CVS Sep 20
Platform: AMD 2000+ running Windows XP

Argl, this is driving me nuts!
In the labyrinth levels in Indy 3 (Venice catacombs,
Castle
Brundwald, Zeppelin), I have problems with people walking
where there are not supposed to walk.
In Venice, it was not much of a problem, Indy can simply
walk over some tunnels.
In Castle Brunwald, I saw it happen only once with a
soldier
standing in a wall. However in the first scene with the
butler at the entrance door, Indy can walk from the top
exit to the right exit and is drawn "over" the table
with the
candles and the stairs. Still no real problem.

The Zeppelin section is really difficult though: the
soldiers
can just run around like they want to, even if there is no
bridge/floor under them, so they seem to "float". This
makes it really difficult to escape them. I finally
managed
to get along by fighting two of them, but I couldn't
get into
that plane (see screenshot, room 41). I finally found that
by clicking on the middle part of the ladder, NOT on the
plane or by moving Indy down the ladder, Indy will enter
the plane, else he will just stand there. I am not 100%
sure
but I think in the original game (played in on an Amiga
back
then), it was enough to click on the ladder or the plane.

In the compatibility list, it says "no known issues" for
Indy 3 VGA, but for Indy 3 *EGA*, it says:
"Indiana may be able to walk in odd places, in some rooms".

I assume this is some problem with the walking boxes,
anyone else experienced this?

Cheers

Toby

Ticket imported from: #1032964. Ticket imported from: bugs/1778.

Attachments (7)

plane.png (17.2 KB ) - added by SF/tobybear 15 years ago.
I want to get on that plane!
indy3.s80 (6.8 KB ) - added by SF/tobybear 15 years ago.
savegame before plane, solider walking on air
boxes.PNG (13.7 KB ) - added by SF/tobybear 15 years ago.
walking boxes room 41
soldier_bottom.PNG (13.6 KB ) - added by SF/tobybear 15 years ago.
floating soldier at bottom
soldier_middle.PNG (13.8 KB ) - added by SF/tobybear 15 years ago.
floating soldier in the middle
soldier_top.PNG (13.8 KB ) - added by SF/tobybear 15 years ago.
floating soldier at top
indy3.s79 (6.0 KB ) - added by SF/tobybear 15 years ago.
savegame before entering zeppelin labyrinth

Download all attachments as: .zip

Change History (23)

by SF/tobybear, 15 years ago

Attachment: plane.png added

I want to get on that plane!

by SF/tobybear, 15 years ago

Attachment: indy3.s80 added

savegame before plane, solider walking on air

comment:1 by fingolfin, 15 years ago

Never heard anything similar to this. in fact I am pretty sure that part
used to work fine.

by SF/tobybear, 15 years ago

Attachment: boxes.PNG added

walking boxes room 41

by SF/tobybear, 15 years ago

Attachment: soldier_bottom.PNG added

floating soldier at bottom

by SF/tobybear, 15 years ago

Attachment: soldier_middle.PNG added

floating soldier in the middle

by SF/tobybear, 15 years ago

Attachment: soldier_top.PNG added

floating soldier at top

comment:2 by SF/tobybear, 15 years ago

Okay, I added some screenshots:
boxes.png are the walking boxes for this room, they seems to
be okay for me.
soldier_bottom, soldier_middle, soldier_top show a soldier
appearing at the bottom(!) of the screen moving straight up
- you better not get in his way.

I though at first my copy of the game had become corrupted,
but I tried it at one of my friends with his copy - same
problem. It is also strange that it appears in all the
labyrinth levels.

comment:3 by fingolfin, 15 years ago

Priority: normalhigh

comment:4 by fingolfin, 15 years ago

Owner: set to fingolfin

comment:5 by fingolfin, 15 years ago

This regression was apparently caused by my fix for bug #809547.
Looking at that particular change, it looks wrong to me, so I'll see if i can
find a better fix for #809547 which avoid the regression described here.

comment:6 by fingolfin, 15 years ago

Resolution: fixed

comment:7 by fingolfin, 15 years ago

This should be fixed now in CVS, please try (may take up to 24 hours for
the fix to appear in the daily builds, obviously :-).

comment:8 by SF/tobybear, 15 years ago

Hi!
I checked with the latest CVS (30-09), but I don't know if the fix is already
active. What was different than before is that I can now hear Indy's
footsteps on the zeppelin bridge (clonk! clonk!), this was not the case in
older builds (20-09).

The soldiers still walk on air though :-(
Since I though that maybe the savegame contained wrong data already, I
restarted from the airport but the same problem. It seems the soldier now
prefer to walk horizontally instead of vertically and sometimes *below* the
bridges instead of above.

Can anyone confirm that in my savegame the soldiers walk on air on his
computer?

UPDATE:
I just started playing Indy3-VGA-English on another computer and noticed
that Indy walks strangely in the Venice catacombs as well. This is nothing
new but I noticed that he does not seem to walk abritrarily, but follow the
path of the walk boxes, although shifted to the right sometimes, making him
walk in the black areas. I checked the room's walkboxes and they seemed
fine, but maybe this problem is a different one:
Could it be that this bug is related to scrolling of the background and the
actors not scrolling with it (or the other way round), so basically a problem
with coordinate calculations on screens larger than the viewing area?
This could explain why the soldiers in the zeppelin can walk horizontally or
vertically in some areas where there is no bridge because the actor/walkbox
calculation is based on another area. Or maybe it is simply the background
image not scrolled correctly, so the actors walk fine, but are displayed at the
wrong positions? But then Indy wouldn't be able to enter the plane at the
right spot....

Hmmm, any ideas?

Would it help if I check with Indy 3 - FM-Towns if it shows the same
behaviour?

comment:9 by fingolfin, 15 years ago

No, the issue definitely is unrelated to scrolling.

A savegame *before* the problem occurs would be more helpful, BTW,
as it's very hard to test using your savegame whether the issue is fixed
or not -- the savegame already starts out with actors outside their
"walkbox", so even if the issue was fixed, upon loading it you get the bad
effect at first...

comment:10 by SF/tobybear, 15 years ago

I just checked again, the problem is still there (I
re-started from the airport), BUT: I think I found out that
the problem only occurs when saving/loading in the
labyrinths! As far as I remember, the original game
interpreter did not allow you to save in the labyrinth
levels, maybe something gets screwed up when ScummVM saves
and loads at these points?

What do you think?

comment:11 by fingolfin, 15 years ago

Resolution: fixed

comment:12 by fingolfin, 15 years ago

If the problem really occurs after loading a savegame, that explains a
lot! Ah yeah, I now see it, "walkdata.point3" is not being save (I actually
wondered if that might be a problem 1-2 years ago =). That one is very
easy to fix (for new savegames, that is, not for existing "broken" ones, I
am afraid).
I'll commit such a change, maybe you can try it in 24 hours and see if it
helps with "new" savegames?

by SF/tobybear, 15 years ago

Attachment: indy3.s79 added

savegame before entering zeppelin labyrinth

comment:13 by SF/tobybear, 15 years ago

Thanks, I will try it out soon!
If others want to test, I uploaded a savegame right before Indy enters the
Zeppelin...

comment:14 by fingolfin, 15 years ago

What is the status of this item?

comment:15 by fingolfin, 15 years ago

Status: newclosed

comment:16 by fingolfin, 15 years ago

Resolution: fixed
Note: See TracTickets for help on using tickets.