Opened 15 years ago

Closed 9 years ago

#1776 closed defect (fixed)

FOA FM-TOWNS: black boxes on screen

Reported by: SF/tobybear Owned by: athrxx
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

Game: Indy 4, FM-Towns, English
Tested with: ScummVM 0.6.1b + CVS Sep 20
Platform: AMD 2000+ running Windows XP

Using both latest stable and CVS, I get nasty black boxes
on the screen with the English FM-Towns version of Indy 4,
see attached screenshots. This problem does not occur with
Indy 4 PC (disk and CD talkie), Indy 4 Amiga and not even
with the Japanese Indy 4 Fm-Towns Demo. The platform is
correctly set to FM-Towns.

The log also says something about 'unknown screen effect'
number 20, 19, 11, ... but that seems to be the case with
most FM-Towns game under ScummVM.

Any ideas?

Cheers

Toby

Ticket imported from: #1032859. Ticket imported from: bugs/1776.

Attachments (2)

i4_fmtowns_1.png (38.2 KB ) - added by SF/tobybear 15 years ago.
black boxes 1
i4_fmtowns_2.png (38.1 KB ) - added by SF/tobybear 15 years ago.
black boxes 2

Download all attachments as: .zip

Change History (27)

by SF/tobybear, 15 years ago

Attachment: i4_fmtowns_1.png added

black boxes 1

by SF/tobybear, 15 years ago

Attachment: i4_fmtowns_2.png added

black boxes 2

comment:1 by fingolfin, 15 years ago

Summary: INDY4 (FM): black boxes on screenFM-TOWNS FOA: black boxes on screen

comment:2 by SF/sexyzeb, 15 years ago

I have lots of white boxes in Atlantis, and the animations
(water, lava, lamps...) seem to be the problem.

comment:3 by fingolfin, 14 years ago

Pretty difficult to do anything about this w/o actually having access to
FOA for FM-TOWNS.

Does this happen with latest CVS, too ?

comment:4 by fingolfin, 14 years ago

Priority: normallow
Status: newpending

comment:5 by SF/tobybear, 14 years ago

Status: pendingnew

comment:6 by SF/tobybear, 14 years ago

Just tested it with CVS from June 1, 05 - same behaviour.
Should I test it with any more recent CVS or wasn't anything
changed in the last 3 days?

Toby

comment:7 by fingolfin, 14 years ago

Thanks! Nothing relevant to this bug has changed in the past
few days, I just wanted to know whether any of the many
changes we made sincec 0.6.1b has had any effect on this :-).

comment:8 by cyxx, 14 years ago

I had a look at the disasm of the indy4towns demo and
noticed a difference in SO_ROOM_FADE. Basically, the
FM-TOWNS interpreter was extended to handle more fade
effects (mainly to deal with extra screen buffers). If one
of these new fade effects is executed,
_switchRoomEffect/_switchRoomEffect2 are not set. I
committed some 'stub' code along with some info to CVS. This
won't help but I think it's better than nothing.

comment:9 by fingolfin, 13 years ago

I wonder whether the black boxes are there because an opcode got changed...
like o5_drawBox... ?

comment:10 by SF/dajmidivx, 13 years ago

Can I ask if this problem is going to be fixed? And if people who work on scummvm dont have in mind to get FM-TOWNS version of game how will they be able to fix bugs? I dont get it...

comment:11 by fingolfin, 13 years ago

You can of course ask whether the problem is going to be fixed. But I am not sure what kind of answer you expect? We don't even know the cause of the problem, so I really can't give you an answer, other than "Hopefully".

As to "And if people who work on scummvm dont have in mind to get FM-TOWNS version of game [...] ?" -- well it's not a matter of "having it in mind", I'd say, but rather one of availability and money. I am sure several of our team members (me included) would be interested in owning that game, which would be a prerequisite to work on fixing this bug. But it's simply very hard to get by, and when one has the chance to buy it, then usually it's outrageously expesnive. We don't have that much money from donation to buy games, you know.

comment:12 by SF/dajmidivx, 13 years ago

Thanks for reply! I understand that FM-TOWNS games are too expensive but I have 5 of them and I can send a copy or upload them somewhere just for you, people who are working on scummVM. I understand that than it would be ilegall, but I would send a copy just to you and noone else, and you could delete it when u finish solving all bug problems... It would be better for everybody, please contact me on my mail, or sent me yours if there is possibility for this...

Thank you!

comment:13 by fingolfin, 13 years ago

Your offer is well meant, but it's not an option in my eyes. A copy is a copy. You can lend your games to somebody temporarily, by giving them your physical media temporarily, but other than that, I see no legal alternative. Doing anything else would put the project into legal hazard, and I am not willing to risk that.

Oh, and it wouldn't be better for *everybody*, anyway: It'd mean I'd spend a lot of work to fix bugs in a game which then I later wouldn't be able to play... Where's the gain in there for *me*? :-)

comment:14 by SF/kaminari, 13 years ago

> I would send a copy just to you and noone else

Dude, your generosity is commendable. I mean, sending the team a copy of an ISO you bought on eBay! Wow.

comment:15 by SF/dajmidivx, 13 years ago

kaminari I just wanted to help! If buying game from ebay is nothing, why dont you buy it?

comment:16 by fingolfin, 13 years ago

Summary: FM-TOWNS FOA: black boxes on screenFOA FM-TOWNS: black boxes on screen

comment:17 by SF/kaminari, 13 years ago

Well, Mr. Smarty Man, maybe because I did that already? Granted, it was another game.

comment:18 by athrxx, 9 years ago

This should be fixed now.

Pleae test again with latest SVN. Be sure to use a build with Hi-Color support (USE_RGB_COLOR). Using old savegames may lead to palette glitches. It would be appreciated if you could play through your Scumm Fm-Towns games again right from the beginning and report any bugs you find.

I set this item to pending.

Florian

comment:19 by athrxx, 9 years ago

Owner: set to athrxx
Status: newpending

comment:20 by athrxx, 9 years ago

Resolution: worksforme

comment:21 by athrxx, 9 years ago

Resolution: worksformefixed

comment:22 by SF/tobybear, 9 years ago

Ok, thanks for the info.
I'll test this in the next two or three days...

comment:23 by SF/tobybear, 9 years ago

Status: pendingnew

comment:24 by SF/tobybear, 9 years ago

wow, it seems to be working now! i only have indy 4 fm-towns at the moment, but the bugs reported by me more than 6 years ago now seems finally to be fixed. no black boxed in the indy 4 intro anymore. great!

comment:25 by fingolfin, 9 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.