Opened 15 years ago

Closed 15 years ago

#1773 closed defect

DIG: Light bridge puzzle bug

Reported by: SF/tobybear Owned by:
Priority: high Component: Engine: SCUMM
Keywords: script Cc:
Game: The Dig

Description

Game: The Dig, English CD version
Tested with: ScummVM 0.6.1b + CVS Sep 20
Platform: AMD 2000+ running Windows XP

My first bug report, hope I did everything right. If not, please tell me.

The problem I have occurs in room 56 ("sparkle"), see attached
screenshot.

Some useful information beforehand:
In "The Dig", you have to activate a light bridge on each of the islands
(spires). This is done by turning a "lens", then activating a "strange
device" by clicking and holding down a "switch". If the light bridge
does not activate, you have to rotate the lense a bit and repeat it.
There is however one light bridge (the one on the "tomb spire") that is
broken. When trying to activate it, you will get a message saying
something like "the warranty on this bridge has run out" or similar.
Later in the game you will get something to pry open a panel below
the "strange device". When you then look at it, you have to solve a
puzzle (guiding a light beam with prisms) to repair the device. After
this, you can simply activate the light bridge like all the others. At
least, this is how the original DOS version of "The Dig" worked. In
ScummVM I encountered some strange behaviour:

1. Using ScummVM 0.6.1b:
Clicking on the lens the first time I enter the room, I can move it
several times. Then clicking on the device and pushing the switch
gives the correct "warranty has run out" message. If I then try to
move the lens again, the cursor disappears and I can't do anything
anymore. I don't think the game has crashed or freezed, it just seems
a script did not terminate correctly. I encountered this at some more
points while playing the game (disappearing cursor), but by
repeatedly clicking with the mouse, it did always return. There are 2
save games attached, the first one (slot 79) is right before the bug:
click on the "strange device", click and hold the switch, wait for
message, click on "exit", click on "lens" -> cursor disappears on my
PC (I could still save, so slot 80 is after this has happened). This was
not really critical for me, because later in the game you receive a
crowbar or something similar (I can't remember how they named it)
that you can use to pry open the panel, solve the puzzle, and *then*
everything works again (turning the lense, activating the device). All
other light bridges in the game have no problem rotating the lense
with ScummVM!

2. I tried several CVS versions from August and September, and they
showed a different behaviour:
You can turn the lens and activate the device, but this time, it will
always activate the light bridge, no matter if the panel has been
opened or the puzzle has been solved! So the player will never see
the beam puzzle or know what the panel is for. Seems like some sort
of script error to me. You can try this again with the attached
savegame: open slot 79 in any recent CVS version, click on device,
click on switch, move lens, repeat until bridge activates - which it
should *not* at this point in the game!

If I should provide any additional information, please tell me.

Regards,

Toby

Ticket imported from: #1031807. Ticket imported from: bugs/1773.

Attachments (3)

room056_bug.png (71.1 KB ) - added by SF/tobybear 15 years ago.
Screenshot
dig.s79 (21.9 KB ) - added by SF/tobybear 15 years ago.
savegame before disappearing cursor
dig.s80 (21.9 KB ) - added by SF/tobybear 15 years ago.
savegame after cursor has disappeared

Download all attachments as: .zip

Change History (14)

by SF/tobybear, 15 years ago

Attachment: room056_bug.png added

Screenshot

comment:1 by SF/tobybear, 15 years ago

Summary: Light bridge puzzle bugDIG: Light bridge puzzle bug

by SF/tobybear, 15 years ago

Attachment: dig.s79 added

savegame before disappearing cursor

by SF/tobybear, 15 years ago

Attachment: dig.s80 added

savegame after cursor has disappeared

comment:2 by SF/tbcarey, 15 years ago

Point #1 [ScummVM 0.6.1b] is probably a repeat or related to:
<a
href="http://sourceforge.net/tracker/index.php?func=detail&aid=1009154&group_id=37116&atid=418820">Bug
1009154</a>

#2 might be related to/introduced by the fix for #1, as this
was never possible for me before the CVS build that
incorporated it. Then again, that might have only been
because the lens couldn't be moved more than a few times
without it locking up.

comment:3 by SF/kaminari, 15 years ago

Probably not very useful, but I finished The Dig (Mac) back in
April with an up-to-date Win32 CVS build (read: from April
^^), and the puzzle definitely worked.

comment:4 by (none), 15 years ago

Regarding #2: I finished The Dig (for the umpteenth time)
just yesterday and it all worked fine. Having played it
numerous times, I have discovered that it is not the light
bridge in the tomb spire that is broken, but the fourth one
that you activate (which might be either be in the tomb
spire or in the map spire, depending on how you are
exploring the islands).
I haven't looked at your savegame, but have you already
activated the other three light bridges?

comment:5 by SF/tobybear, 15 years ago

Well, it is definitely possible to finish The Dig with
ScummVM 0.6.1 (which is what I did) and also with the latest
CVS. With the latest CVS, the cursor disappearing is gone,
but you can probably activate the tomb spire light bridge
without having solved the puzzle (which makes completing the
game somewhat easier, but also more confusing).

With the latest stable release 0.6.1b, you can also still
complete the game, as long as you don't try to move the lens
before you solved the puzzle.

@manwe21: I had only activated the first 2 light bridges in
the save game, not 4.

comment:6 by fingolfin, 15 years ago

Priority: normalhigh

comment:7 by (none), 15 years ago

Having nothing better to do tonight, I took a look at your
savegame (#79) and can confirm that, as I explained
previously, problem #2 is the normal behaviour. Since
problem #1 was fixed in CVS, I guess this can be closed (?).

comment:8 by SF/tobybear, 15 years ago

Yes, but isn't it a bit strange for the player that the bridge can be activated
although the puzzle hasn't been solved yet (problem #2)? As far as I
remember, in the original game, it was never possible to activate the bridge
without solving the light beam puzzle.

comment:9 by (none), 15 years ago

You really know how to remind me of the fact that English is
not my mother tongue... :-) I'll try and rephrase all that
in a clearer fashion.

The Dig is a fairly linear game, but at one point there is a
branch : exploring the planetarium spire, you find both the
blue rod and the green stick and may therefore explore first
either the map spire or the tomb spire.

Therefore, the first two light bridges that you activate are
necessarily those on the museum spire and the planetarium
spire; but the third one might be either on the map spire or
the tomb spire, the remaining one coming fourth.

Furthermore, the game designers decided that one of the
light bridges should be broken and had to be repaired by
playing with the light beams.

They also wanted the game to have some form of 'pedagogy',
and therefore coded it in such a way that the broken bridge
would not be specifically one bridge (say, the one in the
tomb spire), but rather the fourth one the player encounters
(which might be either the one on the tomb spire OR the one
on the map spire).

Hence my asking you in my first post whether you had already
activated the bridge on the map spire.

Now, before posting for a second time, I used your savegame
where I saw that you had indeed not activated that one. I
activated the one on the tomb spire then went to the map
spire, where, as I was fairly certain would be the case, I
*indeed had to open the panel and solve the light beams puzzle*.

Hence, as I wrote (rather hastily, I confess) yesterday, it
is all the normal behaviour and I guess the bug report can
be closed.

comment:10 by SF/tobybear, 15 years ago

@manwe21:
Thank you vey much for your reply, it was not a matter of
you explaining it wrong but rather of me not understanding
correctly. All walkthroughs I had always assumed the tomb
spire bridge to be broken and on my first run playing DIG
with ScummVM, it was also this one. So sorry again and since
the really important bug (freezing after turning lense) is
fixed now, I assume we can safely close this.

Thanks again

Toby

comment:11 by SF/tobybear, 15 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.