Opened 15 years ago

Closed 15 years ago

Last modified 5 weeks ago

#1753 closed defect (fixed)

COMI: Graphic glitches in ship-to-ship fight

Reported by: fingolfin Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

(Using latest CVS).

In ship-to-ship fight, ships leave ugly trails. So far I have no
idea why, but I collected some information.

Oddly, everything seems to be fine until cannons get
fired, at which point things really mess up.

I disabled drawin of all but the main ship actor, yet
the effect remains. That seems to indicate the
problem may be not (at least no directly / not alone)
in the AKOS code, but rather outside it? Need to check
what exactly happens when the cannons get fired...

actor 2 is your ship; actor 18 is its sail
actor 3 is the opponent ship; actor 19 is its sail

All costumes are drawn using codec 1

Script 278 is triggered when you click the right
mouse button, i.e. to fire the canons
It spawns the cannonballs. Each ball actually consists
of three actors (one is the shadow etc.)

Ticket imported from: #1021538. Ticket imported from: bugs/1753.

Attachments (1)

comi.s20 (238.1 KB) - added by fingolfin 15 years ago.

Download all attachments as: .zip

Change History (4)

Changed 15 years ago by fingolfin

Attachment: comi.s20 added

comment:1 Changed 15 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:2 Changed 15 years ago by fingolfin

Bug was caused by the actorHit opcode being implemented
incorrectly (it messed up the actors top/bottom values when it
shouldn't have).

comment:3 Changed 5 weeks ago by Peter Kohaut <peterkohaut@…>

Last edited 5 weeks ago by criezy (previous) (diff)
Note: See TracTickets for help on using tickets.