Opened 15 years ago

Closed 15 years ago

Last modified 4 months ago

#1752 closed defect (fixed)

COMI: Regression in conversation with many choices

Reported by: fingolfin Owned by: Kirben
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Using latest ScummVM CVS.
I think this is a regression caused by my recent text
changes: conversations in COMI with so many options that
the choices have to be scrolled are broken. In the attached
save game, you are facing a pirate in an insult sword fight;
there are many talk options to choose from so the little red
arrows are shown. But if you use them, the old talk options
are not removed, the new ones are just drawn atop them!

Makes it very annoying to play through that part.

Ticket imported from: #1021534. Ticket imported from: bugs/1752.

Attachments (1)

comi.s33 (57.4 KB ) - added by fingolfin 15 years ago.

Download all attachments as: .zip

Change History (6)

by fingolfin, 15 years ago

Attachment: comi.s33 added

comment:1 by Kirben, 15 years ago

That is caused by your recent change to scumm/verbs.cpp to
stop verb backgrounds been reset in COMI.

comment:2 by Kirben, 15 years ago

Owner: set to fingolfin

comment:3 by Kirben, 15 years ago

Verbs regressions are fixed now.

comment:4 by Kirben, 15 years ago

Owner: changed from fingolfin to Kirben
Resolution: fixed
Status: newclosed

comment:5 by Peter Kohaut <peterkohaut@…>, 4 months ago

In a5cf99e6:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.