Opened 16 years ago

Closed 16 years ago

Last modified 17 months ago

#1748 closed defect (fixed)

Loom CD Talkie: Font upside down / flipped horizontally

Reported by: SF/count Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

ScummVM 0.7.0CVS (Aug 30 2004 19:08:01) Features compiled in: Vorbis FLAC MP3 ALSA zLib MPEG2

The fonts in the level question, in the intro, and when having text switched on are upside down ...

Loom CD version, english Talkie.

md5sums of files:

5d88b9d6a88e6f8e90cded9d01b7f082 000.lfl 6642640c52ac20a413d00ca4eb0a7144 901.lfl 0c60481ff858c0e8ab136adab5fa5bdc 902.lfl 6b26151489c428be7c45c25a16e7c902 904.lfl a2be3d9b4c9fceae8033a455d690c0ba disk01.lec ad5148f5eb8e2dba5b41eddef2616750 track1.ogg

Debian GNU/Linux (unstable), kernel 2.6.8.1, gcc 3.3.4

Same problem with ScummVM 0.6.1b

Ticket imported from: #1019228. Ticket imported from: bugs/1748.

Change History (6)

comment:1 by SF/count, 16 years ago

Summary: Font upside down / flipped horizontallyLoom CD Talkie: Font upside down / flipped horizontally

comment:2 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed

comment:3 by fingolfin, 16 years ago

Can't reproduce this, works fine. But your files are not correct -- it appears you renamed 903.LFL to 902.LFL and in the process overwrote the proper 902.LFL (note that those files store the fonts).

Restore your *.LFL files from CD and you should be fine.

comment:4 by SF/count, 16 years ago

Whooops, seems like the habit of renaming files to lowercase backfired badly - should really stop doing it by hand.

Restoring the files from CD helped indeed.

Thanks!

comment:5 by SF/count, 16 years ago

Resolution: worksformefixed

comment:6 by Filippos Karapetis <bluegr@…>, 17 months ago

In 290962ba:

WINTERMUTE: Huge update of detection tables (#1748)

  • WINTERMUTE: Add all changelog engine versions to enum

Source: http://docs.dead-code.org/wme/history.html

  • WINTERMUTE: Fixed name and update detection for Satan and sons

Download:
http://www.freegamearchive.com/play/download/game/satan_and_sons.zip

  • WINTERMUTE: Update detection for Five Lethal Demons

Download:
http://web.archive.org/web/20070705114336if_/http://dead-code.org/5ld/5ld_setup.exe

  • WINTERMUTE: Update detection for Five Magical Amulets

Download:
http://web.archive.org/web/20070505233127if_/http://www.nacht-und-nebel.org/download/fma.exe
Download:
http://www.flint.cba.pl/fusion_7/downloads.php?cat_id=1&download_id=1
Download: http://dead-code.org/5ma/5ma_deutsch.exe

  • WINTERMUTE: Update detection for Actual Destination

Download:
http://web.archive.org/web/20111121174804/http://mrburns.tks.bth.se/ds/ds08/magv08/Actual%20Destination.rar

  • WINTERMUTE: Update detection for Boredom of Agustin Cordes

Download: http://www.cbe-software.com/Games/Boredom/setup_boredom.exe

  • WINTERMUTE: Update detection for Alimardan's Mischief

Buy: https://store.steampowered.com/app/694420/Alimardans_Mischief/

  • WINTERMUTE: Update detection for Alimardan Meets Merlin

Buy: https://store.steampowered.com/app/694430/Alimardan_Meets_Merlin/

  • WINTERMUTE: Update detection for Beyond the Threshold

Download: http://www.nacht-und-nebel.org/pcg/BeyondTheTreshold.zip
NOTE: This game's executable has a very strange version 1.7.94 not
listed in changelog.

  • WINTERMUTE: Update detection for Basis Octavus

Download: http://kraaca.cz/wp-content/files/basis-octavus.zip

  • WINTERMUTE: Update detection for Bickadoodle

Download: https://www.moddb.com/games/bickadoodle/downloads

  • WINTERMUTE: Update detection for Book of Gron: Part One

Download: http://questzone.ru/download/gr/BookOfGron.rar

  • WINTERMUTE: Update detection for Chivalry is Not Dead

Download: https://games.squinky.me/downloads/chivalry/chivalry.zip

  • WINTERMUTE: Update detection for Carol Reed series

I assume that Carol Reed 4 EN use the same engine as Carol Reed 4 RU.
For other versions I assume that Demo and Full versions are sharing the
same engine version.

Demos: http://www.mdna-games.com/
Buy: http://www.mdna-games.com/

  • WINTERMUTE: Update detection for Corrosion

Buy:
https://store.steampowered.com/app/349140/Corrosion_Cold_Winter_Waiting_Enhanced_Edition/

  • WINTERMUTE: Update detection for Dead City

Download: http://dead-code.org/download/games/deadcity.zip

  • WINTERMUTE: Add detection for Dark Fall: Lost Souls

This is a 2.5D game that is out of ScummVM scope

  • WINTERMUTE: Update detection for Dirty Split

Download: https://dreamagination.itch.io/dirty-split

  • WINTERMUTE: Update detection for Dreamscape

Download:
http://web.archive.org/web/20111121174150if_/http://mrburns.tks.bth.se/ds/ds08/vida08/Dreamland.rar

  • WINTERMUTE: Update detection for Dreamcat

Download: https://jennibee.itch.io/dreamcat

  • WINTERMUTE: Update detection for Des Reves Elastiques Avec Mille Insectes Nommes Georges

Download: https://games.squinky.me/downloads/dreaming/dreaming.zip

  • WINTERMUTE: Update detection for DFAF Adventure

Download: https://jennibee.itch.io/dfaf-adventure

  • WINTERMUTE: Add detection for Dr. Bohus

Author: Local Studio
Description: Saving the world from outbreak of a mysterious disease
Language: Czech
Licence: Freeware
Download:
http://www.freegame.cz/hry-ke-stazeni/zdarma/adventury/dr-bohus/13266

  • WINTERMUTE: Update detection for Escape from the Mansion

Download:
https://escapefromthemansion.com/files/EscapeFromTheMansion_v1.3.zip

  • WINTERMUTE: Add detection for Finding Hope

Finding Hope is a hidden object game made with Wintermute engine by
Golden Bough Games.
Try & Buy: https://www.bigfishgames.com/games/5960/finding-hope/

  • WINTERMUTE: Add detection for The Death of Erin Myers

Buy links and details: http://www.viperante.com/short.htm

  • WINTERMUTE: Update detection for Four

Download: http://mentalscraps.com/Four.zip

  • WINTERMUTE: Add detection for Face Noir

This is a 2.5D game that is out of ScummVM scope

  • WINTERMUTE: Update detection for Hamlet

Buy: https://store.steampowered.com/app/222160

  • WINTERMUTE: Update detection for Framed

Download:
http://web.archive.org/web/20111121173916if_/http://mrburns.tks.bth.se/ds/ds08/maqk08/Framed.rar

  • WINTERMUTE: Update detection for James Peris

Download: http://www.jamesperis.com/jamesperisweb-a.htm

  • WINTERMUTE: Update detection for Project Lonely Robot

Download:
http://web.archive.org/web/20111121173634if_/http://mrburns.tks.bth.se/ds/ds07/stgo07/Projectlonelyrobot.rar

  • WINTERMUTE: Update detection for Helga Deep In Trouble

Download: http://helgagame.com/download/helgainstall.exe

  • WINTERMUTE: Update detection for Ghost in the Sheet

Demo: https://ag.ru/games/ghost-in-the-sheet/demos/24978

  • WINTERMUTE: Add detection for K'NOSSOS

Demo: http://svarunentertainment.com/

  • WINTERMUTE: Update detection for Open Quest

Download: https://github.com/JenniBee/openquest/releases/tag/v1.0

  • WINTERMUTE: Update detection for Night Train

Download: https://www.moddb.com/games/night-train/downloads

  • WINTERMUTE: Update detection for Mirage

Download:
http://web.archive.org/web/20111121173733if_/http://mrburns.tks.bth.se/ds/ds08/sasl08/Mirage.rar

  • WINTERMUTE: Update detection for kulivocko

Download: https://ulozto.net/!Ge2FUW8q/kulivocko1-zip

  • WINTERMUTE: Update detection for Looky

Demo: https://mac-bs.de/homepage/downloads/Looky_Demo_Setup.exe
Download: https://bullshit-softworx.itch.io/looky-adventure

  • WINTERMUTE: Add detection for One

Demo: http://rcorp.wz.cz/one/one%20DEMO.rar

  • WINTERMUTE: Update detection for Pizza Morgana

Download: http://pizza-morgana.com/download/episode1

  • WINTERMUTE: Update detection for One Helluva Day

Demo: https://store.steampowered.com/app/603680/One_helluva_day/

  • WINTERMUTE: Update detection for reversion1&2

Buy: https://steamcommunity.com/app/270570 ,
https://store.steampowered.com/app/281060
Source for old versions: https://bugs.scummvm.org/ticket/11009 ,
https://bugs.scummvm.org/ticket/11011

  • WINTERMUTE: Update detection for Project: Doom

Download:
http://web.archive.org/web/20111121180654if_/http://mrburns.tks.bth.se/ds/ds08/vida08/ProjectDoom.rar

  • WINTERMUTE: Update detection for Silent Footsteps

Demo: http://frostlindgames.com/demo.html
Buy: https://store.steampowered.com/app/780740/Silent_Footsteps/

  • WINTERMUTE: Update detection for Paintaria

Download: https://gamejolt.com/games/paintaria/17652

  • WINTERMUTE: Update detection for Pigeons in the Park

Download: https://games.squinky.me/downloads/pigeons/pigeons.zip

  • WINTERMUTE: Update detection for reversion1&2 (Linux & Mac)
  • WINTERMUTE: Update detection for Rosemary

Download: http://gambit.mit.edu/loadgame/rosemary_eula.php

  • WINTERMUTE: Update detection for Shaban

Try & Buy (English): https://www.bigfishgames.com/games/7157/shaban/?pc
Try & Buy (German): https://www.bigfishgames.de/spiele/7157/shaban/?pc
Try & Buy (Spanish): https://www.bigfishgames.es/juegos/7157/shaban/?pc
Try & Buy (French): https://www.bigfishgames.fr/jeux/7157/shaban/?pc
Try & Buy (Japanese): https://www.bigfishgames.jp/games/7157/shaban/?pc
Try & Buy (Dutch): https://www.bigfishgames.nl/spellen/7157/shaban/?pc
Try & Buy (Italian): https://www.bigfishgames.it/giochi/7157/shaban/?pc
Try & Buy (Portuguese):
https://www.bigfishgames.com.br/jogos/7157/shaban/?pc

  • WINTERMUTE: Update detection for Rhiannon

Demos: https://ag.ru/games/rhiannon-curse-of-the-four-branches/demos
Demo:
http://download.fileplanet.com/ftp1/122008/Rhiannon_Demo_C5_setup.exe
Buy: https://store.steampowered.com/app/298140

  • WINTERMUTE: Update detection for Space Invaders demo

Download: https://docs.google.com/file/d/0B1Y5w30FUPM7bk1UQ1BGR2ZVZ2s

  • WINTERMUTE: Update detection for Sofia's Debt

Download:
http://www.artisticsoft.com/flyers/deudadesofia/La%20Deuda%20de%20Sofia.zip
Download:
http://www.artisticsoft.com/flyers/deudadesofia/Sofias%20Debt.zip

  • WINTERMUTE: Update detection for The Kite

Download: https://anatolii.itch.io/the-kite

  • WINTERMUTE: Update detection for The Box

Download: http://web.archive.org/web/20111121180051if_/http://mrburns.tks.bth.se/ds/ds08/maqk08/packages.rar

  • WINTERMUTE: Update detection for The Driller Incident

Download: http://questzone.ru/enzi/files/1645

  • WINTERMUTE: Update detection for The Ancient Mark

Download: https://www.moddb.com/games/the-ancient-mark-episode-1/downloads

  • WINTERMUTE: Update detection for Tanya Grotter dilogy

Buy:
https://www.soft-moscow.ru/goods/tanya_grotter_i_magicheskiy_kontrabas.htm
Buy:
https://www.soft-moscow.ru/goods/tanya_grotter_i_ischezayushchiy_etag.htm

  • WINTERMUTE: Update detection for Space Madness

Demos:
http://web.archive.org/web/20150520160556/http://www.spreadcamp.com/downloads/SM-DEMO_English_and_German.exe

  • WINTERMUTE: Update detection for The Shine of a Star

NOTE: http://questzone.ru/enzi/game/2502 states that this game is
freeware since 29.07.2013
Download: http://forgottenkey.se/TSoaS/TSOAS.msi
Archive: https://web.archive.org/web/20190116104138if_/http://forgottenkey.se/TSoaS/TSOAS.msi

  • WINTERMUTE: Update detection for The White Chamber

Download:
http://www.studiotrophis.com/downloads/thewhitechamber1.7SETUP%20-%20Definitive%20Edition.exe
Download:
http://www.indiedb.com/games/the-white-chamber/downloads/the-white-chamber-17

  • WINTERMUTE: Update detection for Trader of Stories

Download demo: http://www.rudowscy.com/download/theTraderofStories.zip
Full version is not made with Wintermute: http://www.rudowscy.com/tos1/

  • WINTERMUTE: Update detection for Zbang! The Game

Download: http://www.corbomitegames.com/zbang/download.php

  • WINTERMUTE: Update detection for Vsevolod

Download: http://public.ag.ru/vd/c16b434cc9656d4ca5856150c8fc9b18/demos/23267/Vsevolod-Prologue.exe

  • WINTERMUTE: Update some comments
  • WINTERMUTE: Update detection for Toshechka and Boshechka
  • WINTERMUTE: Update detection for Wilma Tetris

Download: http://web.archive.org/web/20160330072540if_/http://dead-code.org/misc/wtetris.zip

  • WINTERMUTE: Add detection for WME Technology Demo 1.2

Download: http://www.dead-code.org/download/wme_demo.zip

  • WINTERMUTE: Update detection for reversion1 (bug 11011)

This fixes https://bugs.scummvm.org/ticket/11011

Version 0, edited 17 months ago by Filippos Karapetis <bluegr@…> (next)
Note: See TracTickets for help on using tickets.