Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#170 closed defect (fixed)

Indy4 - Graphic problems

Reported by: dreammaster Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

I've noticed a few graphic problems in the latest CSV
build (from the 18th). I've included a zip file with
three savegames:

- atlantis.s00

In the Inner Atlantis room with the digging machine.
If you climb down the steps to the ground, none of the
animation is shown. Indy just disappears until he's
redrawn on the ground.

- atlantis.s01

The newest build has some major problems with it's
screen shaking code that weren't present in the older
versions. This save is from when you're driving the
digging machine, and demonstrates the problem.

Also, when you press F5 when an area of the screen is
shaking, it keeps on shaking the screen even though
the dialog is being shown. It results in some major
screen distortions, especially around the cursor.

- atlantis.s02

This savegame is from Algiers. It's experiencing the
same problem as Monte Carlo, in that at least two of
the people start walking through the walls.

I'm using the latest CSV build from the 18th-April
with English Indy4 - Fate of Atlantis CD 5.5.0, on a
Windows 98 machine.

Ticket imported from: #545606. Ticket imported from: bugs/170.

Attachments (1)

atlantis_saves.zip (44.4 KB) - added by dreammaster 17 years ago.
Atlantis Savegames

Download all attachments as: .zip

Change History (6)

Changed 17 years ago by dreammaster

Attachment: atlantis_saves.zip added

Atlantis Savegames

comment:1 Changed 17 years ago by SF/ender

Screen shaking problem - known, and being worked on. The
latest CVS is a slight improvement, although some bugs
remain.

As for the other two, I'll take a look when I can.

comment:2 Changed 17 years ago by SF/ender

Monte Carlo/Algiers bug fixed.

Coming down from the machine is still glitchy, but
apparantly caused by the actor facing the wrong direction
for some reason.

comment:3 Changed 17 years ago by SF/ender

Status: newclosed

comment:4 Changed 17 years ago by SF/ender

I've just commited a FIXME hack to fix the animation
problem. Closing bug report. :)

comment:5 Changed 17 years ago by SF/ender

Owner: set to SF/ender
Resolution: fixed
Note: See TracTickets for help on using tickets.