Opened 15 years ago

Closed 15 years ago

Last modified 5 months ago

#1699 closed defect (invalid)

saved games don't work in 0.6.0 and 0.6.1

Reported by: SF/gameman007 Owned by:
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

I've been playing BASS in 6.0 to a point that I'm 1/2 way
into the game. I formatted my HD saving all saves and
the game files before hand. When I reinstalled
everything I downloaded 6.01 and moved back the game
folder and saves. When I went to play the saves
wouldn't work (set the path en extra as well as saved
games). They all show when I click on the restore
button but nothing else. I read in the FAQ that saves
from older versions wouldn't work so I reinstalled 6.00
but the saves still won't work (in fact they aren't even
listed when I click on restore).. Installed in Windows 98
SE. Any suggestions?

Thanks in advance,

Bill

Ticket imported from: #1002340. Ticket imported from: bugs/1699.

Attachments (1)

Sky-vm.004 (54.5 KB ) - added by SF/gameman007 15 years ago.
saved game

Download all attachments as: .zip

Change History (17)

by SF/gameman007, 15 years ago

Attachment: Sky-vm.004 added

saved game

comment:1 by fingolfin, 15 years ago

I really have to wonder... why do so many people think "0.6.0" = "6.0" or
even "6.00" and "0.6.1" = "6.01" ? These are totally different version
numbers :-). Do you also treat $0.10 and $10.0 dollar as the same? :-)

Anyway, if your saves aren't even listed, that would hint that your
savepath is messed up. If you look at the Scummvm.org homepage, we
have a news item there about a bug in 0.6.1, and also tell you a
workaround for that bug...

comment:2 by fingolfin, 15 years ago

Summary: saved games don't work in 6.00or 6.01saved games don't work in 0.6.0 and 0.6.1

comment:3 by SF/gameman007, 15 years ago

I can see the saves in 0.6.1 they just won't open. I can save
and open new ones. This is my problem. I'd like to continue
my game from where I left off. Was playing in 0.6.0 Now my
saves don't even show up in that version. Is there any way
to access the saves I had in 0.6.0? Wish I had that extra
save path there that's in 0.6.1. he bug you referenced
Fingolfin doesn't apply as I've as stated always been able to
see my saves they just won't open.

comment:4 by SF/gameman007, 15 years ago

What is the status of this item?

comment:5 by fingolfin, 15 years ago

Yes. the bug does apply. You stated that you can no longer see your
games, right? Well, using 0.6.1 probably caused a bad savepath value to
be set in your config file. Which means you can't even use 0.6.0 to
access your savegames at this point. You can solve this by manually
editing your config file, for example.

comment:6 by SF/gameman007, 15 years ago

So how do I edit a config file in 0.6.0 so that they will work
there again? I can see them now when I press the f5 key
they won't open though. by the way control and the number
keys don't work either. Thanks for your help Fingolfin
hopefully we can get this resolved.
Bill

comment:7 by SF/gameman007, 15 years ago

Problem solved Fingolfin. The game works fine and all saves
open in version 0.5.0.

comment:8 by joostp, 15 years ago

By "seeing them" do you mean they get listed in the Save/Load menu,
but for some reason you can't open them? are there any messages on
the console?

You say it works now, but in 0.5.0? (btw, you should really be using
0.6.1b now, as 0.5.* and especially 0.5.0 had some annoying bugs in
BASS)

Have you found the actual cause of the problem when using 0.6.*?
Maybe a problem with permissions or, as Fingolfin already suggested, the
SavePath?

Please elaborate, so this report can be closed.

comment:9 by eriktorbjorn, 15 years ago

I remember that the BASS savegame code was rewritten between
0.5.0 and 0.5.1, "eliminating several situations where
ScummVM 0.5.0 would produce unusable 'frozen' saved games",
though supposedly 0.5.0 savegames could still be loaded by
0.5.1.

Does anyone remember if compatibility with 0.5.0 was kept
for 0.6.0?

comment:10 by joostp, 15 years ago

Nothing was changed since the 0.5.1 changes so all savegames should
still work.
I'd appreciate it if the bug reporter could answer my questions.

comment:11 by joostp, 15 years ago

I just attempted to load the attached savegame and it, unless it got
corrupted somehow, is NOT created with 0.6.0.

comment:12 by SF/gameman007, 15 years ago

Hi Joostb,
As I stated before the only version that works for me is
5.0.0. With 0.6.1 and 0.6.0 the saves show but won't load.
There are no messages of any sort. I guess the 0.5.0 saves
aren't compatable with the other versions, as you saw
yourself when you tried to load the file I sent with my initial
message. Thanks for your attempts to solve the problem
anyway.

Bill

comment:13 by joostp, 15 years ago

It should explicitly say the version is too old, which is what it did for me.
If they work fine with 0.5.0 that's a further indication that they weren't
created with 0.6.0, as you initially claimed, but with 0.5.0 or an even
earlier CVS version.
If you are lucky you can load them in 0.5.1 and save them in the new
format.

I'm closing this item.

comment:14 by joostp, 15 years ago

Resolution: invalid
Status: newclosed

comment:15 by fingolfin, 14 years ago

Component: Engine: Sky
Game: Beneath a Steel Sky

comment:16 by Le Philousophe <lephilousophe@…>, 5 months ago

In 3cca7f93:

CRYOMNI3D: Fix warnings (#1699)

Note: See TracTickets for help on using tickets.