Opened 15 years ago

Closed 15 years ago

Last modified 11 months ago

#1698 closed defect (worksforme)

X11: Screensaver don't detect ScummVM mouse events

Reported by: SF/gilead Owned by: fingolfin
Priority: normal Component: Port: Linux
Keywords: Cc:
Game:

Description

Screensaver don't detect ScummVM mouse events. I was
just actively playing Flight of the Amazon Queen (using
mouse) when X screensaver popped up and the problem
described in bug 1001519 appeared.

System: Debian GNU/Linux
Window manager: Sawfish
ScummVM: 0.6.1
Game tried: Flight of the Amazon Queen (but it isn't
game-related)

Ticket imported from: #1001530. Ticket imported from: bugs/1698.

Change History (8)

comment:1 by fingolfin, 15 years ago

Summary: Screensaver don't detect ScummVM mouse eventsALL: Screensaver don't detect ScummVM mouse events

comment:2 by fingolfin, 15 years ago

This, together with your other bug report, sounds more and more like a
bug in your screensaver :-)
Anyway, you don't tell us what you use as screensaver ?

comment:3 by SF/gilead, 15 years ago

Oh, well, there's only one screensaver in wide use (frankly
I don't know any others :) ) called 'xscreensaver' and
that's what I'm using.

comment:4 by fingolfin, 15 years ago

Summary: ALL: Screensaver don't detect ScummVM mouse eventsX11: Screensaver don't detect ScummVM mouse events

comment:5 by eriktorbjorn, 15 years ago

I know I used to have problems with the monitor going into
power saving mode when playing one of Loki Software's Linux
ports; one that only used mouse input.

As I recall it, the problem went away when I set the
SDL_VIDEO_X11_DGAMOUSE environment variable to 0, but I
never found out exactly what that does, and though I'm
pretty sure I filed a bug report I don't think it was ever
decided whose fault it was.

Anyway, I doubt it's a ScummVM-specific problem.

comment:6 by fingolfin, 15 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed

comment:7 by fingolfin, 15 years ago

I asked multiple people to try to reproduce this, and nobody could...
Nothing we can do about problems we can't reproduce, I am afraid. Even
if we could, it'd probably be a SDL issue, though.

comment:8 by digitall, 11 months ago

Component: --Unset--Port: Linux
Note: See TracTickets for help on using tickets.