Opened 15 years ago

Closed 15 years ago

Last modified 13 months ago

#1697 closed defect (worksforme)

X11: Keyboard/mouse locked after screensaver is activated

Reported by: SF/gilead Owned by: fingolfin
Priority: normal Component: Port: Linux
Keywords: Cc:
Game:

Description

I ran ScummVM in full-screen mode, was watching Flight
of the Amazon Queen intro. Screensaver popped up, and
after I deactivated it by moving mouse the ScummVM was
in windowed mode, and keyboard and mouse were
locked/unavailable. To fix it I had to kill ScummVM
from the text terminal.

I believe that ScummVM should release mouse and
keyboard when its window loses focus (I think it's
possible this may also happen when another app grabs
focus). Another good idea would be to disable
screensaver when running full-screen (eg. mplayer
disables screensaver when run).

System: Debian GNU/Linux
Window manager: Sawfish
ScummVM: 0.6.1
Game tried: Flight of the Amazon Queen (but it isn't
game-related)

Ticket imported from: #1001519. Ticket imported from: bugs/1697.

Change History (10)

comment:1 by fingolfin, 15 years ago

Summary: Keyboard/mouse locked after screensaver is activatedALL: Keyboard/mouse locked after screensaver is activated

comment:2 by fingolfin, 15 years ago

This sounds like a problem specific to SDL on Linux, I'd say. Why would it
change to windowed mode when a screensaver pops up? Sounds strange
:-)

Anyway, somebody who uses Linux, and who knows about Screensaves
on Linux, and about how those interact with apps, should look into this, I
guess.

comment:3 by SF/gilead, 15 years ago

I've done some more checking and I can provide more
information about this. Let's suppose we leave ScummVM
running full-screen for a while so that screensaver gets
activated. Then, two things can happen:
1. You don't touch keyboard and mouse. The screensaver pops
up, changes resolution, displays its own stuff for a few
seconds, then the resolution changes back to the one chosen
by ScummVM. It looks ugly but is no serious problem.
Everything works fine, also after hitting Alt+Enter and
going back to the desktop.
2. You move mouse or hit some key immediately after
screensaver pops up so that it starts its deactivation
sequence (that is, you need to eg. move mouse during these
2-3 seconds when screensaver is visible). Then the
screensaver deactivates itself, the desktop is shown, no
window has focus, keyboard and mouse seems to be blocked.
Then the only solution is to go to one of the text terminals
(eg. Ctrl+Alt+F1) and 'killall scummvm' to fix the situation.

comment:4 by wjp, 15 years ago

I can't reproduce this. XScreensaver doesn't pop up for me
when running scummvm in fullscreen.

(gentoo linux, xscreensaver 4.15, xfree 4.3.0, sdl 1.2.7,
current scummvm cvs)

comment:5 by fingolfin, 15 years ago

So, gilead, what xscreensaver/xfree/sdl versions do you use?

comment:6 by fingolfin, 15 years ago

Summary: ALL: Keyboard/mouse locked after screensaver is activatedX11: Keyboard/mouse locked after screensaver is activated

comment:7 by SF/gilead, 15 years ago

I just pulled the fresh CVS version and confirmed the
problem still happens with it. I use standard versions which
came with Debian Unstable:

max@maxbox:~$ xscreensaver -v
xscreensaver 4.16, copyright (c) 1991-2004 by Jamie Zawinski
<jwz@jwz.org>.
xscreensaver: running as max/max (2000/2000)
xscreensaver: in process 3896.
xscreensaver: 01:23:01: 0: xscreensaver-gl-helper: GL visual
is 0x21 (default).
xscreensaver: 01:23:01: already running on display :0.0
(window 0xa00006)
from process 1346 (max@maxbox).
max@maxbox:~$ XFree86 -version

This is a pre-release version of XFree86, and is not
supported in any
way. Bugs may be reported to XFree86@XFree86.Org and
patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release
versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs).

XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-6
20040707142024 fabbione@fabbione.net)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.23 i686 [ELF]
Build Date: 07 July 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.4.26-1-k7 (herbert@gondolin) (gcc
version 3.3.3 (Debian 20040401)) #1 Sat May 1 21:40:09 EST
2004 T
max@maxbox:~$ sdl-config --version
1.2.7

Here is xscreensaver config file:

max@maxbox:~$ cat .xscreensaver
# XScreenSaver Preferences File
# Written by xscreensaver-demo 4.16 for max on Tue Aug 3
01:06:16 2004.
# http://www.jwz.org/xscreensaver/

timeout: 0:02:00
cycle: 12:00:00
lock: False
lockTimeout: 0:00:00
passwdTimeout: 0:00:30
visualID: default
installColormap: True
verbose: False
timestamp: True
splash: True
splashDuration: 0:00:05
quad: False
demoCommand: xscreensaver-demo
prefsCommand: xscreensaver-demo -prefs
nice: 10
memoryLimit: 0
fade: True
unfade: True
fadeSeconds: 0:00:01
fadeTicks: 20
captureStderr: True
ignoreUninstalledPrograms:False
font: *-medium-r-*-140-*-m-*
dpmsEnabled: False
dpmsStandby: 2:00:00
dpmsSuspend: 2:00:00
dpmsOff: 4:00:00
grabDesktopImages: True
grabVideoFrames: False
chooseRandomImages: False
imageDirectory:

mode: one
selected: 176

programs:
\
[cut]
pointerPollTime: 0:00:05
windowCreationTimeout:0:00:30
initialDelay: 0:00:00
sgiSaverExtension: True
mitSaverExtension: False
xidleExtension: True
GetViewPortIsFullOfLies:False
procInterrupts: True
overlayStderr: True

comment:8 by fingolfin, 15 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed

comment:9 by fingolfin, 15 years ago

I asked multiple people to try to reproduce this, and nobody could...
Nothing we can do about problems we can't reproduce, I am afraid. Even
if we could, it'd probably be a SDL issue, though.

comment:10 by digitall, 13 months ago

Component: --Unset--Port: Linux
Note: See TracTickets for help on using tickets.