Opened 16 years ago

Closed 16 years ago

Last modified 23 months ago

#1689 closed defect (fixed)

ALL: saving is not possible ?!

Reported by: SF/basti630 Owned by: SF/ender
Priority: high Component: Port: Win32
Keywords: Cc:
Game:

Description

Hi everyone, i recently tested ScummVM for the first time and it was a pleasure to play all the beloved games of my childhood once again. (Great program, go on with your work!) Everything runs fine and the sound is great compared to the small pc speaker i used 10 years ago. Of course it would be strange if everything were perfect. While trying to save, i'm always getting an error message telling me: "failed to safe game state to...". I already checked the safepath and tried to change it a dozen times. It is still giving me that failure message. Trying to use another version of scumm didn't work either.

Did anyone ever heard about that problem ? Looking for help using google hadn't turned up any results. Thanks for any help, i would really like to continue playing my games!

Basti.

Ticket imported from: #999122. Ticket imported from: bugs/1689.

Change History (17)

comment:1 by fingolfin, 16 years ago

The problem sounds as if your save path is either invalid or not writable.

comment:2 by fingolfin, 16 years ago

To process your bug report appropriately, we need you to provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build) * Bug details, including instructions on reproducing it * Language of game (English, German, ...) * Version of game (talkie, floppy, ...) * Platform and Compiler (Win32, Linux, MacOS, ...) * Attach a save game if possible * If this bug only occurred recently, please note the last version without the bug, and the first version including the bug. That way we can fix it quicker by looking at the changes made.

This should only take you a little time but will make it much easier for us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 by SF/wolfsangel, 16 years ago

Hey basti

I've got the problem either. Couldn't set a save dir for DotT. But i searched and solved it :)

Simply dl this http://www.scummvm.org/downloads/scummvmwin32.exe and install it over your normal scummvm installation. Then it should be possible. Works here ;)

mfg angel

comment:4 by SF/basti630, 16 years ago

Thanks angel, you were right! I solved my problem. Great!! I will spend some time admiring you while playing :)

comment:5 by eriktorbjorn, 16 years ago

So what you're saying is that it works with the daily CVS snapshot, but not with the version you tried before that? It'd still be interesting to know which version that was. If, for instance, it was 0.6.1, that would be a serious problem.

0.6.1 works fine for me, though...

comment:6 by SF/wolfsangel, 16 years ago

I've dlded scummvm earlier today, cause i've found my old dott cd. So it is version 0.6.1. And it don't work with dott or even Maniac mansion. I've also changed the dir manually in the ini file, no change at all. scummvm reset the save dir when it starts.

comment:7 by eriktorbjorn, 16 years ago

Hmm... Though it doesn't work for me in 0.6.1 if I remove my old scummvm.ini and let ScummVM create a new one for me from scratch.

This is not good...

comment:8 by SF/trinity78, 16 years ago

The problem is, that in the scummvm.ini file the line savepath=none is insert for every game instead of falling back to the default savegame-path.

if you remove the line "savepath=none" for every game (atlantis, tentacle and so on) it jumps back to the savegame- path in the [scummvm] section and everything works fine.

comment:9 by eriktorbjorn, 16 years ago

Looks like it's this change that prevents the bug from happening in the CVS version:

http://cvs.sourceforge.net/viewcvs.py/scummvm/scummvm/gui/launcher.cpp?r1=1.96&r2=1.97

comment:10 by SF/putki, 16 years ago

I updated to ScummVM 0.6.1 on linux, and I'm seeing this problem at least with simon1win, simon2talkie, tentacle and queen.

The problem seems to be that if I choose 'edit game' in the gui and press ok (regardless if I change any settings or not), savepath=None will appear in the game's config in .scummvmrc. Pressing cancel in the edit game dialog doesn't add the line. I can fix the problem by removing the line.

Even editing the save path in the 'edit game' -> 'paths' dialog and pressing ok will cause it to revert to None. At first I thought this was game specific because I'd only edited the config for one game through the qui.

Hope this helps...

comment:11 by fingolfin, 16 years ago

Owner: set to SF/ender
Priority: normalhigh
Summary: saving is not possible ?!ALL: saving is not possible ?!

comment:12 by fingolfin, 16 years ago

The problem is fixed in the upcoming 0.6.1b.

However, you may have to fix your config file, reseting bad savepath valued stored in the game target settings. We probably will post a short guide on this on our homepage when we make the official release... Won't we, Ender? :-)

comment:13 by SF/ender, 16 years ago

Of course :)

comment:14 by fingolfin, 16 years ago

I am working on a small change which will automatically remove "savepath=None" entries from your config file. It's highly unlikely that somebody would use those intentionally, I think :-)

So, when is 0.6.1 coming, Ender? :-)

comment:15 by fingolfin, 16 years ago

The change I mentioned is in, and 0.6.1b was released, so this item can be closed now.

comment:16 by fingolfin, 16 years ago

Resolution: fixed
Status: newclosed

comment:17 by digitall, 23 months ago

Component: --Unset--Port: Win32
Note: See TracTickets for help on using tickets.