Opened 15 years ago

Closed 14 years ago

#1639 closed defect (worksforme)

FT: Sounds gets truncated at end of SMUSH movie

Reported by: eriktorbjorn Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

Full Throttle, English version
CVS snapshot of ScummVM

After Ben crashes with his bike, when he's found by the
journalist, the last line of speech in the SMUSH movie
gets cut off. Instead of "...who can fix anything." I
just get "...who can fix any...".

Possibly related, in the SMUSH movie afterwards some of
Maureen's lines overlap slightly. I have a hunch
there's some function that thinks a sound is done when
all the data has been handed to the mixer, but that's
just a vague feeling.

I tried fixing this by not allowing the movie to stop
until *both* _videoFinished was set and the SMUSH mixer
had stopped playing, i.e. not until isActive() returned
false for all the sound handles. This sort-of worked,
but broke "Esc"aping from the movie.

Ticket imported from: #960866. Ticket imported from: bugs/1639.

Change History (12)

comment:1 by sev-, 15 years ago

This is obviously an iMUSE bug. Reassigning to aqudran.

Also it would be very good if savegame was attached.

comment:2 by sev-, 15 years ago

Owner: changed from sev- to aquadran

comment:3 by eriktorbjorn, 15 years ago

Actually I didn't mean to assign the bug report to anyone,
but apparently the bug tracker assigns SMUSH/Insane bugs
automagically.

I didn't include a savegame since this happens at the very
beginning of the game. The most time-consuming part is
getting through the biker fight and watching the SMUSH
movies, and I don't think it's possible to save during either.

comment:4 by aquadran, 15 years ago

that sounds not imuse bug, but smush bug by stoping smush
too early. i can't check it, because there is allready
escaping bug in mush preventing reproduce it.

comment:5 by aquadran, 15 years ago

when smush is ending, audio tracks are imediately stopped,
that is a little problematic to implement it properly. maybe
switch audio tracks into imuse as originaly

comment:6 by SF/salty85, 15 years ago

I will add a movie, from my other post, which I did not
realize was a re-post of this.

comment:7 by SF/salty85, 15 years ago

ok, I guess I can not add a moive, someone take the one from
the FT: movie cut short thread and post here

comment:8 by sev-, 14 years ago

Just checked. Now it works. Please, test it again.

comment:9 by sev-, 14 years ago

Resolution: worksforme
Status: newpending

comment:10 by eriktorbjorn, 14 years ago

Looks like you're right. At least, I can no longer reproduce
it on this computer.

comment:11 by eriktorbjorn, 14 years ago

Status: pendingnew

comment:12 by sev-, 14 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.