Opened 15 years ago

Closed 15 years ago

#1638 closed defect (fixed)

FT: Music skips at end of SMUSH movie

Reported by: eriktorbjorn Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

Full Throttle, English version
CVS snapshot of ScummVM

When Ben is leaving the Kickstand, there's a SMUSH
movie which ends with Ben saying something like "No one
can stop me. But they try."

Somewhere around this point, the music starts skipping.

Ticket imported from: #960861. Ticket imported from: bugs/1638.

Attachments (1)

ft.ogg (132.9 KB ) - added by eriktorbjorn 15 years ago.
Audio recording of the SMUSH movie

Download all attachments as: .zip

Change History (14)

comment:1 by sev-, 15 years ago

This is iMUSE bug, reassigning to aquadran.

comment:2 by sev-, 15 years ago

Owner: changed from sev- to aquadran

comment:3 by aquadran, 15 years ago

skipping ? music at this place is stoped, i can't reproduce
bug. if you mean scuttering that is duplicated bug.

comment:4 by eriktorbjorn, 15 years ago

Well, the music was breaking up at the very least, i.e. it
played a little, then went silent, the played a little, etc.
It only happened briefly at the very end of the SMUSH movie,
so it's hard to tell if it was skipping parts, pausing, or
playing the same thing over and over.

I can't test if it's still happening because ScummVM crashes
when I try to get the keys from the bartender, so I can't
leave the Kickstand.

If you feel it's a duplicate bug report, please close it.

by eriktorbjorn, 15 years ago

Attachment: ft.ogg added

Audio recording of the SMUSH movie

comment:5 by eriktorbjorn, 15 years ago

Disregard my previous comment. I found a savegame to test
with, and my previous description of the glitch is wrong in
just about every way.

This time, I've made a recording instead.

comment:6 by aquadran, 15 years ago

that doesn't happen for for, anyone more

comment:7 by aquadran, 15 years ago

that isn't imuse music, that is smush track music. from what
i hear from your sample it's at swithing smush movies.

comment:8 by eriktorbjorn, 15 years ago

It still happens for me. I haven't tried to figure out why.

comment:9 by aquadran, 15 years ago

try increase audio track mixer buffer at smush_mixer.cpp at
line 123. it was changed from 400000 to 500000, lately. if
it's not enoght for you, try find optimal value

comment:10 by eriktorbjorn, 15 years ago

500000 fixes the skipping for me, at least on this
particular computer. I experimented with lowering the value
a bit. At 460000 it still sounded fine, but at 450000 it
started skipping slightly again.

comment:11 by aquadran, 15 years ago

strange, lowering shouldn't cause problems, that is buffer
in sound mixer, did you tried higher value: 800000 ?

comment:12 by eriktorbjorn, 15 years ago

I thought you said it was the lower value that caused the
problem to happen.

At 400000 the problem was very noticeable. At 500000 it
wasn't. Lowering the value from 500000 to 450000 made the
problem appear again, though much less noticeably than it
was at 400000.

I didn't try values higher than 500000 because I assumed it
wouldn't make any noticeable difference. At least not on
this particular computer.

comment:13 by aquadran, 15 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.