Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1626 closed defect (fixed)

COMI: After looking by crypt crack, Guybrush moves mouth

Reported by: SF/ys_ Owned by: Kirben
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

That is.
When looking by the hole that make the crack in the Goodsoup
Crypt and talking with the graveyer, Guybrush appears at the
top-left of the screen, and it is very small!

Attached a screenshot

CVS 20040510
Linux 2.6.4
gcc 3.3
Spanish version of the game

Ticket imported from: #954605. Ticket imported from: bugs/1626.

Attachments (1)

bugscummvm-comi2.jpg (50.6 KB) - added by SF/ys_ 15 years ago.
after walking a bit to the right (to be able to see guybrush)

Download all attachments as: .zip

Change History (14)

Changed 15 years ago by SF/ys_

Attachment: bugscummvm-comi2.jpg added

after walking a bit to the right (to be able to see guybrush)

comment:1 Changed 15 years ago by eriktorbjorn

Component: Engine: SCUMM
Game: Monkey Island 3

comment:2 Changed 15 years ago by fingolfin

Does the issue still occur with latest CVS? If so, please attach a save
game with which we can reproduce the problem.

comment:3 Changed 15 years ago by SF/ys_

I thought I explained it bad way....
The correct sentence would start: "AFTER looking by the hole..."

I've lost my old savegames. Well... now I have too much free
time. I'll replay the game. I hope having the savegame tomorrow
or so.

comment:4 Changed 15 years ago by SF/ys_

Here is the savegame.

Well... the bug isn't the same as before. Now, after looking by
the crack, Guybrush is shown correctly, but his mouth is
animated, as if he were talking. After some seconds, the mouth
stops moving. Then you walk to any point and when Guybrush
stops walking, he opens again the mouth.

Attached savegame, just get out of that screen.

comment:5 Changed 15 years ago by fingolfin

Sadly, there is no savegame attached, ys_...

comment:6 Changed 15 years ago by fingolfin

Priority: normallow
Summary: COMI: After looking by crypt crack, Guybrush -> bad positionCOMI: After looking by crypt crack, Guybrush moves mouth

comment:7 Changed 15 years ago by fingolfin

I could reproduce the problem with another savegame of mine. That is,
the new problem you mentioned; the scale of Guybrush indeed is correct
now.

This is merely cosmetical, lowering priority.

comment:8 Changed 15 years ago by SF/ys_

Oh sorry, i surely forgot checking in the checkbox to complete the
upload. :-(

comment:9 Changed 15 years ago by fingolfin

Maybe the recent no_talk_anim / talkStartFrame changes are responsible
for this?
See also bug #1009154 in The Dig <https://sourceforge.net/tracker/
index.php?func=detail&aid=1009154&group_id=37116&atid=418820>
Assigning to Kirben to make him aware of this tracker item, maybe he
has some good idea(s)

comment:10 Changed 15 years ago by fingolfin

Owner: set to Kirben

comment:11 Changed 15 years ago by Kirben

Resolution: fixed
Status: newclosed

comment:12 Changed 15 years ago by Kirben

The Guybrush still moving mouth problem was caused by one
small change been lost in stopTalk() of scumm/actor.cpp
during my changes.
The a->isInCurrentRoom() check is only for scumm 1 - 6
games, scumm7/8 games shouldn't be checked.

comment:13 Changed 15 years ago by fingolfin

Good catch! Two bugs at once :-)

Note: See TracTickets for help on using tickets.