Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1621 closed defect (worksforme)

COMI: Crash at Chapter IV Splash Screen

Reported by: SF/rev01001111 Owned by: aquadran
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

recently purchased the Curse of Monkey Island. I loaded all data
files onto my hard drive and ran the game through ScummVM.
Apart from a few known glitches, everything ran smoothly until I
get to the transition between Chapters 3 and 4 (just after
Guybrush defeats Rottingham). I get the Chapter 4 splash screen
but then an error pops up in the console from which there is no
recovery.

The error states:

ERROR: (7:327:0x24): Chunk type is different from expected:
4360ca8f != 4i484452

Just in case you need to know, I'm running ScummVM 0.6.0 under
Mac OS X (10.3)

Ticket imported from: #950430. Ticket imported from: bugs/1621.

Change History (8)

comment:1 Changed 15 years ago by SF/ender

This is a SMUSH-related crash. Reassigning to aquadran (endian issue?)

comment:2 Changed 15 years ago by SF/ender

Owner: set to aquadran

comment:3 Changed 15 years ago by fingolfin

Priority: normalhigh
Summary: Crash at Chapter IV Splash ScreenCOMI: Crash at Chapter IV Splash Screen

comment:4 Changed 15 years ago by SF/ys_

Spanish version on a GNU/Linux box runs fine. No problems to me.

comment:5 Changed 15 years ago by aquadran

it except AHDR chunk, that tag is always at first of 4 bytes
of datas from begining of file. i can't imagine what could
be. file exist but that file is not smush file. any one more
can reproduce bug ?

comment:6 Changed 15 years ago by aquadran

Priority: highnormal

comment:7 Changed 15 years ago by fingolfin

So it seems we can't reproduce the problem... maybe the data files of
the original poster are corrupt...?
rev01001111, which language is your COMI in (english, german, french,
spanish, ...)
You may want to verify that your data files are not corrupt, too. The
checksums of the SAN files vary with the language, but these MD5s
should be fixed:

MD5 (shared/COMI.LA0) = fe60d6b5ff51b0553ac59963123b5777
MD5 (shared/COMI.LA1) = 09ae3abb98c43df89119466ae3557c0f
MD5 (shared/COMI.LA2) = 468f5ea61bb622284d57e615718b73cc

comment:8 Changed 15 years ago by fingolfin

Priority: normalhigh
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.