Opened 15 years ago

Closed 15 years ago

Last modified 12 months ago

#1616 closed defect (invalid)

ALL: Mouse does not work in fullscreen mode

Reported by: (none) Owned by: SF/ender
Priority: high Component: Port: Linux
Keywords: Cc:
Game:

Description

If I switch to fullscreen or start a game in fullscreen
mode the mouse is no longer working. The cursor stays
in the bottom right corner of the screen. I can use
the arrow keys to move the cursour but when I move the
mouse it skips back to the corner. It works flawless in
normal window mode.

I tried different mouse setups. I will provide more
debug infos, but do not know what is needed to track
this down.

XFree 4.3 on Debian GNU/Linux

$ scummvm -v
Switched to configuration /home/bond/.scummvmrc
ScummVM 0.6.0 (Mar 14 2004 18:01:37)
Features compiled in: Vorbis MP3 ALSA zLib MPEG2

Ticket imported from: #946312. Ticket imported from: bugs/1616.

Change History (9)

comment:1 by fingolfin, 15 years ago

Did you compile ScummVM yourself or is this the stock version provided
by us?
If compiled by yourself, what version of SDL did you use?

All I can say is that I can't reproduce the problem on Mac OS X.

comment:2 by fingolfin, 15 years ago

Priority: normalhigh
Summary: Mouse does not work in fullscreen modeALL: Mouse does not work in fullscreen mode

comment:3 by (none), 15 years ago

The ScummVM version is the Debian package from
Debian/unstable. I just compiled ScummVM from sources by
myself. The effect is the same. Mouse is not working.

It has maybe to do with the closed-source ATI drivers for my
Radeon graphics card. But if I try vesa mode and switch to
fullscreen the whole I can see nothing on screen.

The SDL version is 1.2.7

comment:4 by fingolfin, 15 years ago

I only can repeat that this works just fine for me. Ender, care to
comment?

comment:5 by fingolfin, 15 years ago

Owner: set to SF/ender

comment:6 by SF/ender, 15 years ago

Resolution: invalid
Status: newclosed

comment:7 by SF/ender, 15 years ago

I've seen this with the official Radeon binary-only drivers. The Radeon
drivers have many known issues with... well, everything :)... but in
particular DGA.

I don't know for certain that DGA is the problem, or if you can tell SDL
to not use DGA for fullscreen. However, this problem goes away if you use
a XF4.4 (RC2, if you want to remain DFSG free) with the open-source
Radeon driver.

Last time I tried the XFree4.3 debs in experimental crashed HARD when
trying the radeon DRI driver, but the binary drivers are pretty much just
as useless or unstable IMHO.

In any case, not much we can do. Try reporting the bug to ATI, but I've
reported worse and never ever ever heard back or see bugfixes.

comment:8 by (none), 15 years ago

It seems the bug is fixed with latest version of the ATI
radeon drivers (version 3.9.0).

comment:9 by digitall, 12 months ago

Component: --Unset--Port: Linux
Note: See TracTickets for help on using tickets.