Opened 16 years ago

Closed 15 years ago

#1588 closed defect (fixed)

FM-TOWNS: Wrong text position (regression)

Reported by: (none) Owned by: fingolfin
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

ScummVM 0.7.0CVS (Apr 11 2004 11:40:40)
Features compiled in: Vorbis MP3 zLib MPEG2
Runnig under WinXP

In Loom (floppy version and FM-Towns version, but not
Talkie version), the text used in close-ups appears too
much on the loft of the screen, making it partly
unreadable. The notes on the distaff appear too much on
the left as well (I checked against the original
interpreter that it is indeed the case).

The problem is recent and didn't occur in version
0.6.0. I first noticed it a few days (maybe a week)
ago, but didn't report it then as I thought that it was
the same as # , which was also occurring. Yet, # is now
fixed and the text position remains in current CVS.

I'm attaching two screenshots showing the bug, as well
as a save for Loom EGA (even though it is not really
necessary: just start the game and go straight to the
Elders' building to notice the bug).

Ticket imported from: #933168. Ticket imported from: bugs/1588.

Attachments (4)

closeup.PNG (11.5 KB ) - added by SF/*anonymous 16 years ago.
Screenshot of the bug (close-up)
distaff.PNG (14.4 KB ) - added by SF/*anonymous 16 years ago.
Screenshot of the bug (distaff)
loom.s01 (7.6 KB ) - added by SF/*anonymous 16 years ago.
Savegame (Loom EGA English)
loom-text.diff (1.1 KB ) - added by eriktorbjorn 16 years ago.
Patch against an April 26 CVS snapshot

Download all attachments as: .zip

Change History (22)

by SF/*anonymous, 16 years ago

Attachment: closeup.PNG added

Screenshot of the bug (close-up)

by SF/*anonymous, 16 years ago

Attachment: distaff.PNG added

Screenshot of the bug (distaff)

by SF/*anonymous, 16 years ago

Attachment: loom.s01 added

Savegame (Loom EGA English)

comment:1 by (none), 16 years ago

When I say "I thought that it was the same as # ", I meant:
"I thought that it was the same as # 930385" (forgot to
paste the number before submitting)

comment:2 by fingolfin, 16 years ago

Hm, odd. First I thought that maybe this is caused by a change in
ScummEngine::CHARSET_1(), where I added a check for the actor's
room:
if (a && a->isInCurrentRoom() && _string[0].overhead != 0) {
But changing this back to
if (a && _string[0].overhead != 0) {
doesn't help.

Hm.

comment:3 by fingolfin, 16 years ago

Priority: normalhigh

comment:4 by (none), 16 years ago

The problem is also occurring in Indy 3 EGA and Indy 3 Towns
(but NOT Indy 3 256). The bug is noticeable during fights
(the names etc. at the bottom of the screen are too much on
left) and when reading the Grail Diary (which makes it
rather impossible to read).

comment:5 by fingolfin, 16 years ago

This is probably caused by one of the text changes I made since 0.6.0 ?!?
Just guessing, actually, so far I have no idea...

Erik, maybe you have any insights on this... ? If not, feel free to re-
assign this to me!

comment:6 by fingolfin, 16 years ago

Owner: set to eriktorbjorn

comment:7 by eriktorbjorn, 16 years ago

I think I see what's happening. The text is printed at the
correct *position*, but it's centered rather than
left-justified.

In 0.6.0 we stored the string's 'xpos', 'ypos' and 'color'
to use as default values for the next message (I think).
With the CVS version, we save all the string's parameters.
Including 'center'.

If I make sure that 'center' is cleared, it works for me again.

comment:8 by fingolfin, 16 years ago

Ahhh, that sounds sensible. Feel free to apply that fix (or if you prefer, I
can do it later this week, depending on when I have time).

by eriktorbjorn, 16 years ago

Attachment: loom-text.diff added

Patch against an April 26 CVS snapshot

comment:9 by eriktorbjorn, 16 years ago

Hmm... I'm a bit uncertain now, because when I looked at
0.6.0 a bit closer I noticed that in most cases we do save
everything, including the 'center' flag, but this one case
is different: not only don't we backup the 'center' flag, we
don't touch it at all. Not even to clear it.

To preserve that behaviour, I guess we have to manipulate
_default directly, like in the patch I just attached. Is
that acceptable, or is it too ugly?

comment:10 by eriktorbjorn, 15 years ago

I've applied my suggested, somewhat hacky fix. Feel free to
make a better fix later, but this is the best I can think of.

comment:11 by eriktorbjorn, 15 years ago

Resolution: fixed
Status: newclosed

comment:12 by (none), 15 years ago

Status: closednew
Summary: LOOM: Wrong text position (regression)FM-TOWNS: Wrong text position (regression)

comment:13 by (none), 15 years ago

Sorry to be a spoilsport, but...
Using latest CVS, the bug is indeed fixed in LoomEGA and
Indy3EGA, but still occurs in LoomTowns and Indy3Towns.

comment:14 by eriktorbjorn, 15 years ago

I don't have any of the FM TOWNS games. (Much too rare and
expensive for my taste.) Fingolfin, I seem to recall that
you got the Indy3Towns that someone donated? Could you look
into this?

comment:15 by eriktorbjorn, 15 years ago

Owner: changed from eriktorbjorn to fingolfin

comment:16 by fingolfin, 15 years ago

I'll try to reproduce this if somebody tells me where and how (ideally,
give me a savegame and precise instructions what to do). Manwe21 said
that
the problem is visible in fights. At least when doing the sparring at the
very start of Indy3 (FM-TOWNS version), no problems are visible...

comment:17 by (none), 15 years ago

Status: newclosed

comment:18 by (none), 15 years ago

Eriktorbjorn's fix seems to have worked after all: I still
see the bug using my old savegames, but can't reproduce it
with a fresh start. Sorry about that.

Note: See TracTickets for help on using tickets.