Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1582 closed defect (fixed)

MI2: Intro regression

Reported by: eriktorbjorn Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

Latest CVS snapshot
MI2, english PC version

With the latest CVS snapshot, Elaine and her subtitles
are not drawn correctly. The attached screenshot
explains it better than I can, I think.

(This is as far as I played the intro. There may be
other regressions later, but I don't think they're
worth looking for until this one has been fixed.)

Ticket imported from: #929724. Ticket imported from: bugs/1582.

Attachments (1)

mi2-intro2.png (29.4 KB ) - added by eriktorbjorn 16 years ago.
Screenshot of the regression

Download all attachments as: .zip

Change History (5)

by eriktorbjorn, 16 years ago

Attachment: mi2-intro2.png added

Screenshot of the regression

comment:1 by fingolfin, 16 years ago

In costume.cpp and akos.cpp: Since _outheight can be negative now
(they were changed to be signed, in order to help 64 bit systems),
negative y values aren't filtered out automatically anymore, so we have
to explicitly check for them

comment:2 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:3 by eriktorbjorn, 16 years ago

Could this account for the recent instability (bug #929818)
as well? (When I recompiled ScummVM with electric fence
debugging, it crashed repeatably and I think it was because
of y < 0, causing it to read outside of the mask buffer. If
it also caused it to write outside... well, you get the idea.)

comment:4 by fingolfin, 16 years ago

That is very well possible - but I can't exclude other possibilities, of
course ...

Note: See TracTickets for help on using tickets.