Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1581 closed defect (fixed)

MI2: Difficulty selection screen regression

Reported by: eriktorbjorn Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

Latest CVS snapshot
MI2, english PC version

With the latest CVS snapshot, the text on the
difficulty selection screen is drawn and then removed
almost instantly. See attached screenshot.

Ticket imported from: #929722. Ticket imported from: bugs/1581.

Attachments (2)

mi2-intro1.png (242 bytes ) - added by eriktorbjorn 16 years ago.
Boring screenshot of the regression
restoreCharsetBg.patch (4.2 KB ) - added by fingolfin 16 years ago.
Modify CharsetRenderer::restoreCharsetBg

Download all attachments as: .zip

Change History (8)

by eriktorbjorn, 16 years ago

Attachment: mi2-intro1.png added

Boring screenshot of the regression

comment:1 by eriktorbjorn, 16 years ago

I think this bug was introduced with the removal of
CharsetRenderer::_mask

comment:2 by eriktorbjorn, 16 years ago

Owner: set to fingolfin

comment:3 by fingolfin, 16 years ago

Indeed, and I see how. I have a patch which changes CharsetRenderer::
restoreCharsetBg() not to restore everything from background, but
rather only things which are "covered" by the charset mask.

Patch attached.

by fingolfin, 16 years ago

Attachment: restoreCharsetBg.patch added

Modify CharsetRenderer::restoreCharsetBg

comment:4 by fingolfin, 16 years ago

There are also problems ont he Loom difficulty selection screen; this
patch helps them only partially, since it only restores the charset data on
the uppermost virtual screen. I'll have to revise it to update all virtual
screens.

comment:5 by fingolfin, 16 years ago

Status: newclosed

comment:6 by fingolfin, 16 years ago

Resolution: fixed
Note: See TracTickets for help on using tickets.