Opened 16 years ago

Closed 15 years ago

#1559 closed defect (fixed)

BS1: talking to Pearl in Siria

Reported by: SF/f0xino Owned by: lavosspawn
Priority: high Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

scumm 0.60 quits when George is asking to Pearl about
her (question "Pearl icon").
The quit message is

WARNING: ObjectMan::lockText(2949786): text number has
no text lines!
fetchFrame:: frame -13 doesn't exist in resource.!

Scumm doesn't quit if i turn off the text.

Platform: Linux
Scumm: 0.60
Language: Italian

Tested also with cvs 20040319; same situation.

Ticket imported from: #922774. Ticket imported from: bugs/1559.

Attachments (1)

SAVEGAME.000 (957 bytes ) - added by SF/f0xino 16 years ago.
Crash Point

Download all attachments as: .zip

Change History (8)

by SF/f0xino, 16 years ago

Attachment: SAVEGAME.000 added

Crash Point

comment:1 by fingolfin, 16 years ago

Owner: set to lavosspawn

comment:2 by eriktorbjorn, 16 years ago

I can't reproduce this in the English "Sold-Out" version
even if I tell it to use Italian subtitles. Though Pearl's
exact response to when you ask her about herself does depend
on at the very least whether or not you've spoken to Duane
first so it's possible that I'm testing a different case.

Of course, it's also quite possible that the Italian version
is different.

comment:3 by eriktorbjorn, 16 years ago

I realized that the savegame works with my version as well,
but I still can't reproduce the crash so I guess my version
is different.

comment:4 by fingolfin, 15 years ago

Priority: normalhigh

comment:5 by fingolfin, 15 years ago

Is there any way Francesco can find out which precise version he has, so
that he can post the info here?

comment:6 by lavosspawn, 15 years ago

Resolution: fixed
Status: newclosed

comment:7 by lavosspawn, 15 years ago

Can't reproduce it with my version, either.
My version doesn't even try to open resource 2949786, so I
can't tell what this resource should contain, in order to add a
serious workaround.

If the engine can't find a text string now, it should
show "Error: Text not found." instead.
Not too great, but at least it won't crash anymore. And
speech output should still be correct.

Note: See TracTickets for help on using tickets.