Opened 15 years ago

Closed 15 years ago

Last modified 10 years ago

#1554 closed defect (worksforme)

MI2: random crashes in Part 4

Reported by: SF/snugnun Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

I have been using ScummVM Quick and Easy and the
application compiles a build each time I play. I made
sure to compile the most recent version before I played.
When I checked the file version of the executable file, it
said Version 7.

I cannot reproduce the bug identically. During Part 4,
where Lechuck is chasing Guybrush with the voodoo doll
as Guybrush tries to collect items and get away from
LeChuck, the game randomly crashes when I try to
attempt an action. The action is not necessarily the
same each time. For instance, it will crash when I try to
pick up one object, but if I restart the game and retry,
it will be able to pick up the object that caused the
crash in the first place but crash when I try for a
different object. The amount of playtime between
crashes is not consistent. That is, it might play for
longer than the last time it crashed, but it happens
eventually.

The game is in English, originally from a CD called
Monkey Island Madness from the LucasArts Archives
Volume 3.

I am on a PC with XP.

Attached is a screenshot of what happens when the
game crashes. It looks like a debug box appears with
some information in it.

Thanks in advance.

Ticket imported from: #920887. Ticket imported from: bugs/1554.

Attachments (1)

MI2_bug.JPG (56.7 KB) - added by SF/snugnun 15 years ago.
Screenshot of the command box that appears upon crash

Download all attachments as: .zip

Change History (21)

Changed 15 years ago by SF/snugnun

Attachment: MI2_bug.JPG added

Screenshot of the command box that appears upon crash

comment:1 Changed 15 years ago by eriktorbjorn

Owner: set to fingolfin

comment:2 Changed 15 years ago by eriktorbjorn

I wonder if this could be related to fingolfin's recent
object-naming changes. I don't know exactly what those
changes were, but I didn't see anything like this when I
played through MI2 with a pre-0.6.0 snapshot.

comment:3 Changed 15 years ago by fingolfin

<shrug>. Maybe. Impossible for me to exclude the possibility.

Not going to do anything abouit it, though, as long as I get no savegame.

comment:4 Changed 15 years ago by fingolfin

Owner: fingolfin deleted
Summary: MI2 random crashes in Part 4MI2: random crashes in Part 4

comment:5 Changed 15 years ago by eriktorbjorn

I couldn't reproduce the bug when playing through part four
with the CVS version. Of course, that could be because all
my savegames - I started with one just before part 4 - were
made with a 0.6.0 branch snapshot...

comment:6 Changed 15 years ago by fingolfin

Status: newpending

comment:7 Changed 15 years ago by fingolfin

As I stated before, it's impossible to do anything sensible about this
report w/o any savegame from the bug submitter.

comment:8 Changed 15 years ago by SF/snugnun

Status: pendingnew

comment:9 Changed 15 years ago by SF/snugnun

Oh no! I'm sorry but I deleted it. Guess this will be one of
those unsolvable ones until someone else encounters it and is
not dumb enough to delete the savegame files.

comment:10 Changed 15 years ago by fingolfin

Resolution: worksforme
Status: newclosed

comment:11 Changed 15 years ago by fingolfin

Ah well, closing this then. If you ever run into this again, feel free to
reopen it or file a new bug report.

comment:12 Changed 15 years ago by SF/michel75

Related to this:

PART4: When opening the root beer box the following message
appears

"ERROR 90:830:0X818B New name of 830 overflows name table
(50 = max)".

Regards

comment:13 Changed 15 years ago by SF/jenshn

I have almost the same error. The game crashes at random
points during part 4. The errors are different depending on
the point where the game crashes.
I have seen these to:
"ERROR (90:834:0X7BDB): New name of 834 overflows name
table
(50 = max)".

"ERROR (91:858:0X6CDA): New name of 885 overflows name
table
(50 = max)".

comment:14 Changed 15 years ago by eriktorbjorn

834 and 885 are the internal id numbers of the objects that
get their names changed.

ScummVM has to keep track of which objects have had their
names changed, and for Monkey Island 2 it can handle up to
50 different objects. The error message reflects which
object it was that caused the table to overflow.

Could it really be that MI2 changes the name of more than 50
objects? As has been pointed out, a savegame might be useful
here...

comment:15 Changed 15 years ago by fingolfin

Folks, this is a *closed* bug report. Please don't post unrelated stuff on
it. If you have a problem, file another new bug report, please.

comment:16 Changed 15 years ago by eriktorbjorn

It was I who referred to this bug report, since michel75
reported the exact same error message as in the original
screenshot. And you did say "If you ever run into this
again, feel free to reopen it or file a new bug report."

I just wish he would have done as I asked and attached a
savegame instead of just another comment. :-)

comment:17 Changed 15 years ago by SF/michel75

Hey, I opened a new bug report and just added the savegame
to it. Thanx.

comment:18 Changed 15 years ago by SF/michel75

Hey, I opened a new bug report and just added the savegame
to it. Thanx.

comment:19 Changed 15 years ago by SF/michel75

Hey, I opened a new bug report and just added the savegame
to it. Thanx.

comment:20 Changed 10 years ago by Kirben

Owner: set to fingolfin
Note: See TracTickets for help on using tickets.