Opened 16 years ago

Closed 16 years ago

Last modified 10 months ago

#1541 closed defect (fixed)

GUI: Window layering problem in browser

Reported by: SF/msephton Owned by: fingolfin
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

ScummVM 0.6.0 - 14 March 2004
Mac OS 10.3.3

Background: when adding a game under Mac OS X you are
presented with a standard path selection dialog. The main function
of this dialog is to locate a path/directory. To do so you can use a
number of operating system GUI controls, such as back and
forward buttons, file system view and a path drop down.

Detail: Under Mac OS X selecting the path drop down at the top of
the path selector should show a menu of the directory tree up to
the current path, displayed one below the other. This seems to be
raised but at a z-order below the file selection box itself.

Reproduction: Run Mac OS X. Start ScummVM windowed. Click add
game. Click the path drop down menu at the top of the path
selection dialog. Notice how it is displayed below the file selector.
In some circumstances when the directory tree to ScummVM is not
very long you may not be able to see the drop down at all, in this
instance press ESC to resume normal dialog control.

Ticket imported from: #917700. Ticket imported from: bugs/1541.

Change History (4)

comment:1 by fingolfin, 16 years ago

Owner: set to fingolfin
Summary: Strange path selector box behaviourGUI: Window layering problem in browser

comment:2 by fingolfin, 16 years ago

Fixed in CVS.

comment:3 by fingolfin, 16 years ago

Resolution: fixed
Status: newclosed

comment:4 by digitall, 10 months ago

Component: --Unset--GUI
Note: See TracTickets for help on using tickets.